If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

XForms does not initialize properly after XSLT transformation applied

RESOLVED DUPLICATE of bug 294612

Status

Core Graveyard
XForms
--
major
RESOLVED DUPLICATE of bug 294612
12 years ago
a year ago

People

(Reporter: hinfoxbt, Assigned: aaronr)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051103 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051103 Firefox/1.6a1

After an XSLT transformation applied to the XHTML Firefox does not display initial values from the model and output element does not display text at all.

I made a simple xhtml file which uses a stylesheet with identity transformation. This can be used to reproduce the bug. If the stylesheet invocation is commented out then everything went fine.

Reproducible: Always

Steps to Reproduce:
1. Open an XForms form which uses an xslt transformation and have initial values assigned in the model.

Actual Results:  
The initial values does not display at all.

Expected Results:  
The initial values should display correctly.

The default theme was used. I could not verify that this occurs on other architectures and/or operationg systems.
(Reporter)

Comment 1

12 years ago
Created attachment 201799 [details]
The simple xhtml file which produces the bug
(Reporter)

Comment 2

12 years ago
Created attachment 201800 [details]
The identity transformation used on the xhtml file
(Reporter)

Updated

12 years ago
Version: unspecified → Trunk
(Reporter)

Comment 3

12 years ago
Created attachment 201879 [details]
Updated testcase to reflect the discovered problem

This seems to be an initialization problem because XForms initialization events does not fire properly after an XSLT transformation regardless of what the transformation does. If the transformation does not take place (such as commented out) then they fire properly and the form also initialized properly.

Therefore I modify the summary because this reflects the problem more closely and I make this testcase.

This testcase should produce three modal alerts (one for xforms-model-construct, xforms-model-construct-done and xforms-ready) and initialize the form properly but it does not produced this alerts and the form does not initialized.

It is possible to initialize the XForms processor manually from the page? If it is then this should be a temporary workaround but I did not find anything about the manual initialization of the XForms processor.
Attachment #201799 - Attachment is obsolete: true
(Reporter)

Updated

12 years ago
Severity: normal → major
Flags: testcase+
Keywords: testcase
Summary: XForms initial values does not display when XSLT transformation applied → XForms does not initialize properly after XSLT transformation applied

Updated

12 years ago
Assignee: nobody → aaronr
Component: General → XForms
Product: Firefox → Core
QA Contact: general → spride

Comment 4

12 years ago

*** This bug has been marked as a duplicate of 294612 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.