data-URLs get obfuscated in View Source window

RESOLVED DUPLICATE of bug 235344

Status

()

Toolkit
View Source
RESOLVED DUPLICATE of bug 235344
12 years ago
9 years ago

People

(Reporter: Veronica, Unassigned)

Tracking

1.8.0 Branch
x86
Windows XP
Points:
---
Bug Flags:
blocking1.8rc2 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.8b4) Gecko/20050910 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

Data-URLs are like:
<img src="data:image/jpeg;base64,<encoded-image-data>" />

Thus the image binary data is embedded in the HTML code, per HTML 4.0.1 recommendation. When viewing source on these pages with Firefox 1.5RC1 (and beta2), all you get is <img src=<loooooooooooots of spaces> alt="" />.

To fix this bug, i would suggest to cache the exact data the HTTP server sends you. Now i see lots of moz-blah embedded which surely didn't get sended by the HTTP server. View Source is used for debugging the EXACT source code - so please don't touch even a single byte. Only syntax-highlighting (colours) is useful IMO.

Affected:
- Firefox 1.5 Beta2 and RC1 on Windows XP/luna

Not affected:
- Firefox 1.5 Beta1 on FreeBSD (custom built)

This may be a regression from Beta1 to Beta2.

Reproducible: Always

Steps to Reproduce:
1. Go to a webpage with data URL's
2. Right click on page, select "View Page Souce"

Actual Results:  
Instead of the img src, all there is is about 7000 spaces.

Expected Results:  
Display img src data, with every byte as-is sended by the HTTP server. View Souce is meant for viewing the data behind the page, not what Mozilla parses it into.

To fix this bug, i would suggest to cache the exact data the HTTP server sends you. Now i see lots of moz-blah embedded which surely didn't get sended by the HTTP server. View Source is used for debugging the EXACT source code - so please don't touch even a single byte. Only syntax-highlighting (colours) is useful IMO.
(Reporter)

Updated

12 years ago
Flags: blocking1.8rc2?
Version: unspecified → 1.5 Branch
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051103 Firefox/1.5 ID:2005110321

WFM
there's just 1 line with the image data with no spaces

Comment 2

12 years ago
This doesn't seem like a critical stop ship bug to me. How did 1.0 handle this?

Comment 3

12 years ago
Duplicate of/related to bug 293875 -> bug 235344?

Comment 4

12 years ago
Seems like a low-impact issue that will not block rc2.
Flags: blocking1.8rc2? → blocking1.8rc2-
If I reduce text size with Ctrl+-, the image source becomes visible at some point.

*** This bug has been marked as a duplicate of 235344 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.