Bookmark Toolbar Folder steals keyboard mnemonic from context menu if only one bookmark beginning with that letter

RESOLVED DUPLICATE of bug 266076

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 266076
12 years ago
12 years ago

People

(Reporter: Dan Weiss, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

After opening a bookmark folder from the bookmarks toolbar, I right click on a bookmark to make a context menu appear.  When I press the underlined letter on a menu, it opens a bookmark beginning with that letter instead.

Reproducible: Always

Steps to Reproduce:
1. Open a folder on the bookmarks toolbar
2. Have ONE bookmark in that folder begin with a letter (for example, 'D')
3. Right click on any bookmark in that menu to bring up a context menu
4. Press a letter on the keyboard 'D' to activate an item in the context menu


Actual Results:  
Firefox opens the bookmark beginning with that letter 'D'

Expected Results:  
Firefox would execute the command on the context menu (delete the bookmark for 'D').

It also happens with other letters, including 'R'.  It does not happen if there is more than one bookmark beginning with the letter, it properly selects the context menu item in that case.

Comment 1

12 years ago
Duplicate of/related to bug 266076?

*** This bug has been marked as a duplicate of 266076 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.