mail imported from outlook return to unread status after rebuilding folder msf file

RESOLVED FIXED

Status

Thunderbird
Migration
--
critical
RESOLVED FIXED
12 years ago
5 years ago

People

(Reporter: Giacomo Fonderico, Assigned: Bienvenu)

Tracking

(Blocks: 2 bugs, {dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by 207156])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

Mail imported from outlook don't have thunderbird headers (X-Mozilla-Status,...).
So if you mark these mails as read, they come back as unread after reconstruction of msf file.

Reproducible: Always

Steps to Reproduce:
1.import outlook pst profile
2.mark mail imported as read
3.delete msf file for its folder

Actual Results:  
Mail are in unread status

Expected Results:  
Mail are in read status

Have marked mail as new
(Reporter)

Comment 1

12 years ago
If possible, it would appreciate a rebuild functionality that can add thunderbird headers after importation.
In our case we have migrated about 40 Pc from Outlook to Thunderbird, and after 6 months we have imported mails in inconsistent status (X-... headers are not in the mails header).
(Reporter)

Comment 2

12 years ago
Sorry, I omitted version of Thunderbird.
The problem exist for version 1.0.3, the latest test was made with version 1.0.6 (20050716)
(Assignee)

Comment 3

12 years ago
if you delete a message, and do a context menu compact this folder, the x-mozilla-status headers will be added as part of the compact process.
(Assignee)

Comment 4

12 years ago
what version did you use to do the importing? I thought that bug was fixed a while ago, that import didn't added x-mozilla-status.
(Reporter)

Comment 5

12 years ago
The last import was made with thunderbird 1.0.6 (20050716)
(Assignee)

Comment 6

12 years ago
darn, it was fixed for Outlook Express but never Outlook. 

Compacting folders is the only way to get those x-mozilla-status lines into the messages. And compacting won't do anything unless at least one message is deleted.
(Reporter)

Comment 7

12 years ago
I've tried to delete a message from folder and compacting it after deletion, this add TB headers to mail imported and resolve the problem.
Do you think is a good idea to submit a bug for "compact folder" utility?
(Assignee)

Comment 8

12 years ago
We've already got a command File | compact folders that will compact all the folders in a given account. The auto-compact feature will compact folders in all accounts (tools | options | advanced | offline and disk space - automatically compact folders when it will save xx KB. So we're unlikely to add a separate utility. We'd rather spend resources making compaction more automatic, and/or support mail formats that don't require compaction.
(Assignee)

Comment 9

12 years ago
Created attachment 201889 [details] [diff] [review]
possible fix for problem at import time

I haven't tested this, since Outlook refuses to register itself as the mapi client on this machine, but I'll try it on a different machine.
Assignee: mscott → bienvenu
Status: UNCONFIRMED → ASSIGNED
(Reporter)

Comment 10

12 years ago
I,am sorry for my bad english, in comment nr 7 I don't ask you to develop a new utility for compacting folders correctly.
My question is: Is a bug of actual "compact folder" functionality adding missing headers only if I delete a message from the folder?
If the functionality exist, through context menu or option setting is the same, I think it must work correctly.
I hope to not abuse of your patience.

Comment 11

9 years ago
similar?  Bug 160027 (less active, old?)

related? bug 219269

Comment 12

8 years ago
(In reply to comment #9)
> Created an attachment (id=201889) [details]
> possible fix for problem at import time
> 
> I haven't tested this, since Outlook refuses to register itself as the mapi
> client on this machine, but I'll try it on a different machine.
@David: what were your results ? (if you remember ;)
Maybe we could try it out ?
(Assignee)

Comment 13

8 years ago
Wow, I really don't remember - if you have a setup where you can try it out, that would be great (I don't know if the patch even applies anymore)

Comment 14

8 years ago
I've applied the patch manually so hopefully the build would be a success and I will let you know about the results.

Comment 15

8 years ago
Unfortunately compilation fails:

../../../../mozilla/dist/include/xpcom\nsCRT.h(295) : warning C4005: 'FILE_ILLEG
AL_CHARACTERS' : macro redefinition
        ../../../../mozilla/dist/include/msgbase\msgCore.h(216) : see previous d
efinition of 'FILE_ILLEGAL_CHARACTERS'

d:/mozilla/source/mailnews/import/outlook/src/nsOutlookMail.cpp(595) : error C20
65: 'MSG_FLAG_READ' : undeclared identifier
d:/mozilla/source/mailnews/import/outlook/src/nsOutlookMail.cpp(597) : error C20
65: 'MSG_FLAG_ATTACHMENT' : undeclared identifier
d:/mozilla/source/mailnews/import/outlook/src/nsOutlookMail.cpp(609) : error C38
61: 'EscapeFromSpaceLine': identifier not found
d:/mozilla/source/mailnews/import/outlook/src/nsOutlookMail.cpp(611) : error C38
61: 'EscapeFromSpaceLine': identifier not found
d:/mozilla/source/mailnews/import/outlook/src/nsOutlookMail.cpp(663) : error C38
61: 'EscapeFromSpaceLine': identifier not found
d:/mozilla/source/mailnews/import/outlook/src/nsOutlookMail.cpp(1061) : warning
C4018: '<' : signed/unsigned mismatch
(Assignee)

Comment 16

8 years ago
ah, yes, life has moved on quite a bit since that patch. I'll see if I can't quickly get you an updated patch.

Comment 17

8 years ago
(In reply to comment #16)
OK, great, the other option could be to fix bug 219269 ;)
(Assignee)

Comment 18

8 years ago
Created attachment 362624 [details] [diff] [review]
unbit-rotted patch

this needs to be fixed no matter what...
Attachment #201889 - Attachment is obsolete: true
Blocks: 475607
Blocks: 219269

Comment 19

8 years ago
> 'EscapeFromSpaceLine': identifier not found
these errors are preventing successful build, though they are not related to the patch hmm ?
(Assignee)

Comment 20

8 years ago
Are you building on the comm-central trunk? Those errors are not related to the patch. Does the patch apply cleanly?

Comment 21

8 years ago
Przemyslaw: tried to build again?

Comment 22

8 years ago
I've had some conversation with David, here is my last comment:
(didn't get reply yet)

patched build didn't changed anything for me
imported mail from outlook does not have X-Mozilla-Status headers,
after marking message as read they also do not show up and so after
rebuilding index messages are reset to unread state
I've tested with outlook 2003 and 2007
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b3pre) Gecko/20090217 Shredder/3.0b2pre
(Assignee)

Comment 23

8 years ago
Can you use the debugger to see if the lines that the patch added are executed?

Comment 24

8 years ago
"status update":
I've added printfs to the modified functions.
There are no printfs from the nsOutlookMail.cpp so this means that the
patched function was not executed.
(waiting for other patch / patched file to play with).
Duplicate of this bug: 388776
Przemyslaw, are you waiting on bienvenu?
Severity: normal → critical
Keywords: dataloss
(Assignee)

Comment 27

8 years ago
I think we don't have a patch that fixes the issue, is my recollection, and I'm more or less just guessing about what to patch, since I can't recreate the problem.
Przemyslaw do you still have a testcase?

Giacomo aka the reporter seems to be gone.
Whiteboard: [patchlove]

Comment 29

5 years ago
This bug has been fixed by fixing Bug 207156 comment 93 (attachment 490452 [details] [diff] [review]), that fix was based on this bug's patch made by David. It is included into TB since v7 (IIRC).

Comment 30

5 years ago
David Bienvenu, as you have produced a patch here, can you confirm comment 29?
(In reply to :aceman from comment #30)
> David Bienvenu, as you have produced a patch here, can you confirm comment
> 29?

I'll trust mike on this one.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [patchlove] → [fixed by 207156]
You need to log in before you can comment on or make changes to this bug.