z-index for absolutely positioned element inside of element with {overflow: hidden} is ignored instead of applied

RESOLVED FIXED

Status

()

defect
--
major
RESOLVED FIXED
14 years ago
9 months ago

People

(Reporter: mtanalin, Assigned: roc)

Tracking

({testcase})

1.8 Branch
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

Absolutely positioned element nested into container that has {overflow: hidden} is shown BELOW next (after container) element that has {position: absolute} or {position: relative}. It takes place _independently_ of (positive) {z-index} value of first absolutely positioned element. Removal of {overflow: hidden} from container OR {position} from last ("next") element gets nested (positioned absolutely) element entirely visible.

Reproducible: Always

Steps to Reproduce:
1. make element with overflow: hidden;
2. make element nested into element created at step 1;
3. make element that has {position: absolute} (or {position: relative}) and follows after element created at step 1.

OR see the testcase
Actual Results:  
The element nested into container is BELOW the next-after-container element independently of (positive) {z-index} for nested element.

Expected Results:  
The element nested into container should be ABOVE the next-after-container element if nested element has positive z-index value (100 for example).

The problem takes place in both Forefox 1.07 and Firefox 1.5 RC 1 as well as in early branch builds of Firefox 1.5. Opera 8.5 (build 7700) and IE6 (6.0.2900.2180) renders the testcase CORRECTLY -- as expected results are.
Assignee: nobody → roc
Component: General → Layout: View Rendering
Keywords: testcase
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → Trunk
Reporter

Updated

14 years ago
Version: Trunk → 1.8 Branch
I seems to be fixed in my debug build that has the "frame display lists" patch in it (bug 317375).
Depends on: 317375
Testcase doesn't work with
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060124 Firefox/1.6a1 ID:2006012405
(black box next to grey box, different from IE)

Testcase does work with
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1 ID:2006012613
(black box above grey box, same as IE)

--> RESOLVED FIXED (by bug 317375)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

10 years ago
Duplicate of this bug: 487740
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.