Allow for "Detach As..." (renaming attachments when detaching them)

RESOLVED DUPLICATE of bug 479200

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 479200
13 years ago
8 years ago

People

(Reporter: David von Oheimb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: 

When detaching an attachment, it is often very handy to change the file name
(analogously to "Save As..."), e.g. when the orginal name is inappropriate.

Note that the obvious workaround, viz. renaming the file after detaching it, 
is not only cumbersome, but makes the X-Mozilla-External-Attachment-URL invalid.

Reproducible: Always

Steps to Reproduce:

Comment 1

12 years ago
*** Bug 316443 has been marked as a duplicate of this bug. ***

Comment 2

12 years ago
Given the bits and widgets are already available for the save as... this sounds like it only needs some hookup code to reuse existing tools.  Definate plus for when the detach function gets turned on in release builds. 
QA Contact: front-end

Updated

10 years ago
Assignee: mscott → nobody
(Reporter)

Comment 3

8 years ago
There have been attempts to solve this problem, but so far not successful:
https://bugzilla.mozilla.org/show_bug.cgi?id=448576
https://bugzilla.mozilla.org/show_bug.cgi?id=479200
(Reporter)

Updated

8 years ago
Severity: enhancement → normal
Version: unspecified → 3.0

Comment 4

8 years ago
Duping forward. (More info in bug 479200.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 479200
You need to log in before you can comment on or make changes to this bug.