If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Open Message Folder" in advanced search should focus selected message in existing 3-pane (don't open a new window)

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED WORKSFORME
12 years ago
8 years ago

People

(Reporter: Erik Wikström, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: version 1.0.7 (20050923)

The Open Message Folder i the search dialog opens the selected message in a new window, I would prefer if it would open the selected message in a already open Main Window (if one exists). While I've found uses of having many Firefox-windows open at one I've never had a need for more than one Thunderbird.

Reproducible: Always

Steps to Reproduce:
1. Make a search for something in some folder such that results are returned.
2. Select one of the results.
3. Click the Open Message Folder-button.

Actual Results:  
A new Thunderbird-window opens up with the message selected.

Expected Results:  
The already existing Thunderbird-window would get focus and the message is selected.

Some people might actually like the current behaviour better, perhaps there should be some option so that users can choose.

Updated

12 years ago
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows Server 2003 → All
Hardware: PC → All
Summary: Open Message Folder (in search) opens a new window → Prefer "Open Message Folder" (in search) select folder in existing 3-pane (don't open a new window)
Version: unspecified → Trunk
Does bug 258371 describe what you are looking for?
Or bug 262012?
(Reporter)

Comment 2

12 years ago
> Does bug 258371 describe what you are looking for?
> Or bug 262012?

Sorry, but no. While the preview-pane mentioned in bug 258371 sounds like a realy useful feature it does not address my concern. I realise now that I might not have been clear in my problem-description so I will try again.

My problem is that when I perform a seach I might be interested in not just the message matching my seach but also replies or followups (like in a maillist), so I want to be able to get the message matching my search selected in the main-window. This can be done with the "Open Message Folder"-button, my grievance is the fact that the button opens a new window instead of reusing an already existing window.

This problem has been mitigated by the introduction of the quick-seach-bar but still exists for more advanced searches.
So you want the message focused in the search results to a) be opened in the original 3-pane window and b) focus on the message in question.  

"b" is reasonable for even the average user, and arugably more useful than merely opening the folder - in improvement I'd welcome.  But "a" - some people will prefer the current behavior of a new 3-pane window and I'm probably on that side of the fence. 

This is two requests and two bugs. a) requires a preference setting so as not to disturb current behavior and b) simply improves current behavior of open folder. FWIW b) may be more likely to get patched sooner.
Summary: Prefer "Open Message Folder" (in search) select folder in existing 3-pane (don't open a new window) → "Open Message Folder" in advanced search should focus selected message in existing 3-pane (don't open a new window)
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> So you want the message focused in the search results to a) be opened in the
> original 3-pane window and b) focus on the message in question.  
> 
> "b" is reasonable for even the average user, and arugably more useful than
> merely opening the folder - in improvement I'd welcome.  But "a" - some people
> will prefer the current behavior of a new 3-pane window and I'm probably on
> that side of the fence. 
> 
> This is two requests and two bugs. a) requires a preference setting so as not
> to disturb current behavior and b) simply improves current behavior of open
> folder. FWIW b) may be more likely to get patched sooner.

b) is already implemented and working (in 1.5) so it's just one (this) bug. With regerds to a) I agree with you that there perhaps should be a setting (as stated in the origional bug-report).
(In reply to comment #4)
>
> b) is already implemented and working (in 1.5) so it's just one (this) bug.
> With regerds to a) I agree with you that there perhaps should be a setting (as
> stated in the origional bug-report).

sorry, you're quite right about b - I got fooled. I tested with 1.5, which focuses the message but it does NOT always bring the message into the display (so I stupidly assumed it wasn't focused).  "Open folder" on a message from search that is in the same folder as what is focused in 3-pane, but where the message isn't currently displayed (I have 3pane sorted by date focused on a recent message, then selected an old message from the search)

Trunk version 3 alpha 1 (20060411) seems better, which makes sense because I think some focus bugs were fixed.  However, I don't know if it's perfectly fixed.
QA Contact: front-end

Updated

9 years ago
Assignee: mscott → nobody
This looks worksforme on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.8) Gecko/20100212 Shredder/3.0.2pre

From "Search messages", select result msg, then "Open in folder"
-> will select and focus the msg in existing 3-pane main tab of TB window, as requested by this bug.

Wayne might wish to file a followup bug for a preference to open a *new* tab with the msg focused, so as to not lose the original focus in main tab for those who prefer. In fact, I'd even consider having that preference in the options UI.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.