Shared remote cal is unreliable

RESOLVED DUPLICATE of bug 329570

Status

RESOLVED DUPLICATE of bug 329570
14 years ago
13 years ago

People

(Reporter: Petr, Assigned: mostafah)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

We had did try to use calendar/sunbird as shared calendar on small workgroup.
Shared calendar .ics file was stored on linux apache (webdav module) server.
Clients was windows and linuxes users, who subcribed this remote calendar.
Permission was set to allow users to modify this file. The option "Reload
remote calendars on startup" was set ON.
We had found, that events are losed very ofen.

Reproducible: Always

Steps to Reproduce:
1. Reload remote calendar from all clients
2. Lets user Tom to add event "Date on Monday".
3. Let user Joe to add event "Date on Tuesday".

Actual Results:  
The event "Date on Monday" is losed, after Joe added his event.

Expected Results:  
All new events should be added and saved to shared remote calendar file.

When user did add new event, this event is updated immediately to server. OK.
But calendars of another users are not updated. When another user adds his new
event, the previous event is losed.

The solution (or workaround) of this fatal problem is to autocheck (reload)
remote calendar file from server to client before client updates his new event
to server.
Without fixing this problem, actual calendar/sunbird is not usable for shared working.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 329570 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.