Cannot display chinese characters in personal toolbar (bookmark), bookmark window, sidebar and status area.

VERIFIED INVALID

Status

()

defect
P3
normal
VERIFIED INVALID
20 years ago
20 years ago

People

(Reporter: wcalee, Assigned: ftang)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; N; Linux 2.2.12-20 i586; en-US; m14)
BuildID:    2000030913

Chinese characters can be displayed correctly in the browser, but they cannot be
displayed in the personal toolbar, bookmark window, sidebar, and the status bar.
I have attached a screenshot of a popup of the personal toolbar.

My system is running Redhat 6.1 with the following from CLE 0.8p1 installed:
- XFree86-3.3.5-7CLE.i386.rpm
- XFree86-SVGA-3.3.5-7CLE.i386.rpm
- XFree86-libs-3.3.5-7CLE.i386.rpm
- XFree86-xfs-3.3.5-7CLE.i386.rpm
- taipeifonts-1.2-12.noarch.rpm


Reproducible: Always
I think we fix this already. Do you have problem with your old bookmark ? Do  
you start mozilla under Chinese locale when you import them ? 
If you visit an Chinese page, and do a "bookmark " add curent page", you should 
see them correctly. 
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
- The default language of my system is "en_US". (I prefer to leave
  the menu items, etc in english) In mozilla, I have set the character 
  coding to "Auto-Detect (Traditional Chinese)".

- In build 2000031013, after I do "bookmark > add current page", the 
  chinese characters in the bookmark still does not display correctly.
  (I have tried that in both en_US and zh_TW.Big5 mode.

In the M13 Release:
- If system language is "en_US", bookmarks in chinese does NOT display
correctly.
- If system language is "zh_TW.Big5", bookmarks in chinese are displayed
correctly.

In build 2000031013:
- In both cases, bookmarks in chinese does NOT display correctly.

Here's the output after I change locale to "zh_TW.Big5" and run mozilla:
(build 2000031013)
------------------------------------------------------------------------
MOZILLA_FIVE_HOME=/home/leeal/moz
  LD_LIBRARY_PATH=/home/leeal/moz
       SHLIB_PATH=/home/leeal/moz
          LIBPATH=/home/leeal/moz
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
Profile Manager : Profile Wizard and Manager activites : Begin
Profile Manager : Command Line Options : Begin
Profile Manager : Command Line Options : End
ProfileManager : GetProfileDir
ProfileManager : GetProfileDir
Profile Manager : Profile Wizard and Manager activites : End

Gdk-WARNING **: Missing charsets in FontSet creation


Gdk-WARNING **:     ISO8859-1


Gdk-WARNING **:     BIG5-0

WEBSHELL+ = 1
WEBSHELL+ = 2
assuming d&d is off for Navigator
nsCollationUnix::Initialize mLocale = zh_TW.Big5
nsCollationUnix::Initialize mCharset = Big5
nsCollationUnix::Initialize mLocale = zh_TW.Big5
nsCollationUnix::Initialize mCharset = Big5
WEBSHELL+ = 3
Setting content window
It's NOT UTF-16LE- byte 217(d9)
It's NOT UTF-16BE- byte 220(dc)
failed to set the page title.
Document http://www.mozilla.org/ loaded successfully
Document: Done (3.198 secs)
WEBSHELL+ = 4
------------------------------------------------------------------------
A little side note: is it possible to let the bookmark auto detect
GB/BIG5 characters?
This morning when I start mozilla I found that somehow it can 
display chinese in the bookmark. So I think I must be missing 
something yesterday and I just carried out some more tests.
Here's the result:

1) Problem with [Bookmarks -> Add Current Page]:
   Procedures:
   - change system locale to "en_US"
   - logout system and re-login
   - delete the ~/.mozilla directory
   - run mozilla
   - goto http://www.singtao.com/
   - Bookmarks -> Add Current Page
   --> seems that the chinese characters saved are corrupted
       because I can't read it even by reading bookmarks.html.
   --> screen shot of bookmark attached as Snapshot 1
   --> same thing happened when locale is zh_TW.Big5 instead of
       en_US. (Snapshot 2)

2) More tests:
   Test 1:
   - change system locale to "zh_TW.Big5"
   - logout system and re-login
   - delete the ~/.mozilla directory
   - run mozilla to create profile, then quit mozilla
   - copy my bookmark from Netscape 4.72 to Mozilla
     (ie, cp ~/.netscape/bookmarks.html ~/.mozilla/mozProfile/)
   --> chinese display in bookmark OK. (Snapshot 3)

   Test 2:
   - change system locale to "en_US"
   - logout system and re-login
   - delete the ~/.mozilla directory
   - run mozilla to create profile, then quit mozilla
   - copy my bookmark from Netscape 4.72 to Mozilla
     (ie, cp ~/.netscape/bookmarks.html ~/.mozilla/mozProfile/)
   --> no chinese in bookmark (Snapshot 4)
   - change system locale to "zh_TW.Big5"
   - logout system and re-login
   - run mozilla
   --> still no chinese display in bookmark

   Test 3:
   - change system locale to "zh_TW.Big5"
   - logout system and re-login
   - delete the ~/.mozilla directory
   - run mozilla to create profile, then quit mozilla
   - copy my bookmark from Netscape 4.72 to Mozilla
     (ie, cp ~/.netscape/bookmarks.html ~/.mozilla/mozProfile/)
   --> chinese display OK (Snapshot 3)
   - change system locale to "en_US"
   - logout system and re-login
   - run mozilla
   --> chinese display still OK (Snapshot 5)
Posted image Snapshot 1
Posted image Snapshot 2
Posted image Snapshot 3
Posted image Snapshot 4
Posted image Snapshot 5
ftang: sorry if you find my bug report to be confusing. :p

In summary, what I think is the problem is that:
1) Seems to me that the default bookmark file does not work
   with chinese.
2) Once the bookmark is working (using procedure in Test 3), it
   works even when system locale is not chinese and "add current
   page" works. If not, it still does not work after I change 
   system locale to chinese. Seems to me that it's a portability
   problem of the profile/bookmark.
3) Some people (like me) prefer to leave system locale to english
   but wants to read chinese. I think it's best if the 
   profile/bookmark is independent of the system locale.

hope this helps...
leeal- what you report is actually three part of the problem:
1. Importing bookmark file from your 4.x bookmark file
2. Add new bookmark in seamonkey
3. view bookmark file thorugh viewing bookmark.html

The first will only do correctly if your system is set to Chinese locale. In 
order to make seamonkey bookmark system work for multilingual, we decide to use 
UTF-8 to store the boomark entries in seamonkey, this mean there is a importing 
procedure. We depend on the system locale to figure out the system charset 
in order to import that from the 4.x bookmark file, then we keep the entries in 
UTF-8 so we can have both traditional Chinese and Simplified Chinese (and 
Korean/Japanese, so on) bookmarks. Therefore, it is very critical the locale set 
correctly when you import the the bookmark file (it will be done automatically 
when you first create the moz profile)
2. This should always work. If it didn't then it is a bug.
3. This is not guarantee to work. We are changing the bookmark format to use 
UTF-8 so we can store multilingual bookmark. 

I will retest this tomorrow

Add waterson/rjc to the cc list. waterson/rjc, I will do more test and may 
assing to you if it is truely a problem. 
about your question
>A little side note: is it possible to let the bookmark auto detect
GB/BIG5 characters?

There are no detection code associate with bookmark charsets.
There are detection code related to browser page loading. 
mark this M16
Target Milestone: --- → M16
Is this still a problem ?
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
have not heard back from leeal@earthing.net for over a week. Mark this invalid 
untill he reopen it.
Here is the response from Albert Lee
Subject: 
            Re: about Bugzilla bug 31511
       Date: 
            Thu, 27 Apr 2000 13:23:08 -0400
      From: 
            Albert Lee <leeal@earthling.net>
        To: 
            Yung-Fong Tang <ftang@netscape.com>
        CC: 
            leeal@earthling.net, ciqamv@netscape.com
 References: 
            1




Hi, Tang, the problem seems to be fixed.
However, I still have some concerns about the bookmark 
conversion process.
1) If there are chinese characters in the old bookmark
   from Netscape 4.xx, and the user does not set his
   locale to Big5 or GB, the chinese characters in the
   converted bookmark file will not be displayed correctly.
   In this case, is it possible to fix the bookmark?
2) If locale is BIG5 when converting the bookmark, it
   does not convert GB characters correctly. Is it
   possible to handle them both?

I would suggest mozilla to give a warning message to the
user before doing the conversion, and to have an option
to select the original locale manually.

Albert Lee
Keep this bug as Resolved Invalid
Verified as Invalid.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.