HTML Comment made visible if it includes -- within the message other than -->

RESOLVED DUPLICATE of bug 120385

Status

()

--
trivial
RESOLVED DUPLICATE of bug 120385
13 years ago
13 years ago

People

(Reporter: codermsu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

<!-- Title -- Subtitle -->

I don't know if this is valid HTML comment or not, but in IE, the comment is not displayed.  In Firefox, all text after <!-- shows up in the browser.  



Reproducible: Always

Steps to Reproduce:
1. I created an html page with <!-- text -- text --> and checked it in the browser.
2.
3.

Actual Results:  
text -- text --> evaluates as text in the browser window. 

Expected Results:  
Not displayed the HTML comment.

<!-- <!-- text -- text --> resolves the issue.  I assume the literal string '-->' should be looked for or --[^\w+]> or something.
(Reporter)

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 120385 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
The problem with checking specifically for -- as the end delimiter for a comment is in situations where commenting out a section of a page is helpful to the developer for whatever reason.  
You need to log in before you can comment on or make changes to this bug.