Closed Bug 315146 Opened 14 years ago Closed 11 years ago

removing table rows that are children of table (not tbody) leaves space due to pseudo row-groups

Categories

(Core :: Layout: Tables, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: dbaron, Assigned: bzbarsky)

References

Details

(Keywords: testcase)

Attachments

(1 file)

1.30 KB, application/xhtml+xml; charset=UTF-8
Details
[ Based on a report I got in email with a more complicated testcase. ]

Removing a TR that is a child of a TABLE (rather than a child of a TBODY; valid in XHTML) causes extra space to be left in the table.  The problem (from layout debugger) is that extra row group frames are left around.  This is a specific instance of the problems described by bug 162063, but I wanted to get this testcase on file with its own bug.

Steps to reproduce:
 1. load testcase (to be attached)
 2. press the upper "Add Row" button a few times
 3. press the upper "Delete Row" button a few times

Actual results:
 With each "Delete Row", the top cell moves down a tiny bit

Expected results:
 The top cell should always be in the same position, as it is for the lower set of buttons and table.
Attached file testcase
Summary: remoing table rows that are children of table (not tbody) leaves space due to pseudo row-groups → removing table rows that are children of table (not tbody) leaves space due to pseudo row-groups
(Note that this testcase is unusual among testcases for bug 162063 in that it involves no style manipulation at all, only DOM tree manipulation.  But I *think* bug 277995's testcase may have similar characteristics, and may even be the same bug, but it's a good bit more complicated.)
confirmed on osx.
if i remove a table row, which is a direct child of a table and not a tbody, and afterwards append a new row, i get a space which grows if i keep removing and adding.

using a tbody solves this issue.
Note also that this bug (and probably a bunch of the other noticeable pseudo-frame bugs) may be fixable not only by fixing the pseudo-frame code, but by fixing empty pseudo-frames so they don't take up any space (which they probably shouldn't).
Keywords: testcase
Fixed by checkin for bug 162063.  Added test.
Status: NEW → RESOLVED
Closed: 11 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Assignee: nobody → bzbarsky
You need to log in before you can comment on or make changes to this bug.