Buttons on tiny scrollbars redrawn incorrectly

VERIFIED DUPLICATE of bug 29949

Status

()

P5
minor
VERIFIED DUPLICATE of bug 29949
19 years ago
18 years ago

People

(Reporter: jruderman, Assigned: eric)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: round off bug.)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Steps to reproduce:
1. Open http://bugzilla.mozilla.org/
2. Size the browser window so that the horizontal scrollbar, vertical 
scrollbar, or both have no thumb.  Try with various amounts of space between 
the two scrollbar buttons.
3. Move around the document by pressing those buttons.

(On Win32, you can't make the window really tiny horizontally. If you need to, 
open the sidebar to make up for this effect.)

You'll notice that the buttons slowly change as the page scrolls, as if mozilla 
was trying to draw a thumb on top of the scrollbar buttons but failing.  The 
effect is that when you're scrolled to the right, the right button appears to 
stay depressed, etc.

Another problem occurs when the window is squeezed even more, so that both the 
horizontal and vertical scrollbars move halfway into the corner below the 
vertical scrollbar: the overlapping buttons don't pop back up when you release 
the mouse button.

Comment 1

19 years ago
davidr8 : I'm not seeing this at all on win98 2000031009. However, I'm not 
entirely certain that I'm following your description. Perhaps you could 
elaborate and/or attach a screenshot. Thanks.
(Reporter)

Comment 2

19 years ago
Created attachment 6446 [details]
Up button on vertical scrollbar messed up
(Reporter)

Comment 3

19 years ago
Created attachment 6447 [details]
Down and right scrollbar buttons stuck as depressed

Comment 4

19 years ago
Thanks. So I did understand what you were describing, but I can't duplicate 
the second attachment scenario. In the first attachment, I'm not clear what 
the problem is (unless it is a small white line that I can't recreate either).
What build are you using?

Comment 5

19 years ago
Reproduced using 31109 NS verification build on Win98.  
Assigning to evaughan as p5 for M20
Assignee: trudelle → evaughan
Priority: P3 → P5
Target Milestone: M20
(Reporter)

Comment 6

19 years ago
(Reply to jrgm)

Yeah, I am referring to the small white line, although it's not limited to 
white lines. dark grey lines and misplaced arrows happen too, making the button 
look depressed, or making the "inner" (closer to the empty elevator) half of 
the button get drawn as depressed while the "outer" half gets drawn as raised.

Builds - 2000 030913 and 2000 031108 on Windows 98.

Comment 7

19 years ago
Mass move of all M20 bugs to M30.

Comment 8

19 years ago
Mass move of M20 bugs to M30
Target Milestone: M20 → M30

Updated

19 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 9

19 years ago
This is because of a round off error converting from twips to pixels.
Status: NEW → ASSIGNED
Whiteboard: round off bug.
(Assignee)

Comment 10

19 years ago

*** This bug has been marked as a duplicate of 29949 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 11

19 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.