If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

replace weburls to anchors in composed mail's <style> in <head>

VERIFIED DUPLICATE of bug 234210

Status

Thunderbird
Message Compose Window
--
major
VERIFIED DUPLICATE of bug 234210
12 years ago
12 years ago

People

(Reporter: Adam Brunner, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

I composed mail, with <style type="text/css"> in <head>, and I put there a background: #color url(http://.../image.jpg);

After send the mail, when it arrives, in the mail's source, there had been replaced the backgrounds to background: #color url(<a href="http://.../image.jpg">http://.../image.jpg</a>);



Reproducible: Always

Steps to Reproduce:
1. Compose mail with EditHTML extension (http://nic-nac-project.de/~kaosmos/edithtml-en.html)
2. Place a custom <style> to the <head> with background: #color url(http://external/url/image.jpg)
3. Send it to your e-mail address
4. View the recived mail's source
Actual Results:  
The background will not displayed, 'couse in the <style> the background image's url is replaced with an anchor.

Expected Results:  
Leave the URL as it is.

Comment 1

12 years ago
I think this is a dupe; see bug 234210 comment 0 and 31).

Have you copied the bogusly-modified url() correctly? It should read:
    url(<a class="moz-txt-link-rfc2396E"
           href="http://.../image.jpg">http://.../image.jpg</a>);

Comment 2

12 years ago

*** This bug has been marked as a duplicate of 234210 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

12 years ago
(In reply to comment #1)
> I think this is a dupe; see bug 234210 comment 0 and 31).
> 
> Have you copied the bogusly-modified url() correctly? It should read:
>     url(<a class="moz-txt-link-rfc2396E"
>            href="http://.../image.jpg">http://.../image.jpg</a>);
> 

Sorry, copied wrong, the correct is this:
background: #color url(<a class="moz-txt-link-freetext" href="http://.../image.jpg">http://.../image.jpg</a>);

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.