Last Comment Bug 315194 - Reentrance with multiple X displays
: Reentrance with multiple X displays
Status: RESOLVED DUPLICATE of bug 135137
:
Product: Toolkit
Classification: Components
Component: Startup and Profile System (show other bugs)
: unspecified
: x86 NetBSD
: -- minor (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-05 04:43 PST by Hanspeter Roth
Modified: 2008-07-31 04:30 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Hanspeter Roth 2005-11-05 04:43:36 PST
User-Agent:       Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.7.12) Gecko/20051003 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.7.12) Gecko/20051003 Firefox/1.0.7

Occationally I also work with multiple X displays and thus Firefox should be started multiple times. But when started on the second X display this "Choose User Profile" dialog pops up. It even occurs when started with "-P default".     
But Firefox should run independantly when startd on different X displays. It should not open this "Choose User Profile" dialog when started on a diffeent X display.

Reproducible: Always

Steps to Reproduce:
1. startx -- :0
2. start Firefox
3. Ctrl-Alt-F2, login
4. startx -- :1
5. start Firefox

Actual Results:  
When started on X display :1 the "Choose User Profile" dialog pops up.


Expected Results:  
The "Choose User Profile" dialog should not pop up.
Comment 1 Jo Hermans 2005-11-05 08:22:12 PST
You can't start Firefox multiple times with the same profile - that why the "choose profile" dialogbox pops up, to force you to use different profiles. See bug 135137.

Note that if you want to run multiple Firefoxes on the same display, each with a *different* profile, you need the workaround in bug 222661 comment 1.

*** This bug has been marked as a duplicate of 135137 ***

Note You need to log in before you can comment on or make changes to this bug.