Shockwave reports no version at www.clevermedia.com.

RESOLVED DUPLICATE of bug 321704

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 321704
13 years ago
11 years ago

People

(Reporter: Kenneth, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.8) Gecko/20051025 Firefox/1.5

When trying to run any of the Shockwave games at www.clevermedia.com Shockwave 10.1.0.11 reports "This game requires Shockwave 8.5. You'll need to upgrade to be able to play it. (You have version )" - that is no version number.

I've tried both Firefox 1.5 Beta 2 and RC1, with the same result. I'm not sure, but it seems Shockwave 10.1.0.11 can't report which version it has, when running Firefox 1.5. This was never a problem with Firefox 1.0.x. However, trying Shockwave games at www.shockwave.com works fine. I'm hoping for a fix of this bug before 1.5 final. Keep up the good work!

Reproducible: Always

Steps to Reproduce:

Comment 1

13 years ago
Does it report the version you use when you look at the Shockwave test under http://www.macromedia.com/shockwave/welcome/?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
Yes, it reports 10.1r11. The same as http://clevermedia.com/game.php?help/versions
Version: unspecified → 1.5 Branch
(Reporter)

Comment 3

13 years ago
All games at http://www.clevermedia.com/game.php should be Shockwave games with this error message. The Shockwave games by CleverMedia I've found to work with Firefox 1.5 so far are at http://justsolitaire.com/, http://justjigsawpuzzles.com/ and http://gamespark.com/.

Comment 4

12 years ago
See bug 321704
It is highly likely that the referenced material would work with the system locale decimal symbol set to a period, but not if it's set to a comma. Can not check since the clevermedia.com site seems to be down
(Reporter)

Comment 5

12 years ago
You are right. When changing system locale decimal symbol to period, www.clevermedia.com works just fine. This would mean that Firefox 1.5 running on any non-English Windows should have this bug. As far as I know, most languages except English use decimal comma instead of decimal point. I have e-mailed Clevermedia, and they thought it could be some bug in Firefox 1.5 implementation of Javascript, since that's what they use to check if the right Shockwave version is installed. However, since Clevermedia is American and hence are using decimal point, they couldn't reproduce this error.

Comment 6

12 years ago
(In reply to comment #5)
> However, since Clevermedia is American and
> hence are using decimal point, they couldn't reproduce this error.

bug 321704 contains steps to reproduce the bug on US systems.

Though the people at Clevermedia might know best, it is most likely that they are using either a value() or float() call on a string representing the version inside Shockwave, which breaks with the wrong decimal symbol.

 

(Reporter)

Comment 7

12 years ago
(In reply to comment #6)
I didn't mean that Clevermedia couldn't reproduce the error, only that I understood why it worked when they tried Firefox 1.5 with decimal period on a US system. I e-mailed them about this bug back in November. Yesterday I e-mailed them about the reason of the bug, which you gave me. I did suspect it could have something to do with me using Swedish Firefox or Windows. The drawback of changing to decimal period from decimal comma is e.g. problems with office programs.

Reading your bug report at
https://bugzilla.mozilla.org/show_bug.cgi?id=321704
it seems the same bug is also reported at
https://bugzilla.mozilla.org/show_bug.cgi?id=319318
https://bugzilla.mozilla.org/show_bug.cgi?id=320817
https://bugzilla.mozilla.org/show_bug.cgi?id=318756
However it doesn't seem to be anyone working on a patch for this bug, so I suppose it's not likely to be fixed for Firefox 1.5.0.1, or any time soon.

> Though the people at Clevermedia might know best, it is most likely that they
> are using either a value() or float() call on a string representing the version
> inside Shockwave, which breaks with the wrong decimal symbol.

Unfortunately I'm not a programmer, just a user. Is Shockwave using an internal scripting language similar to JavaScript? If so, does this mean there's no bug in the JavaScript implementation of Firefox 1.5, so that the bug is only affecting Shockwave and certain other plugins ?

Do you know why http://www.fieldofview.com/pano-fullscreen/show.php?file=climbing-tree.jpg
does work, and
http://www.fieldofview.com/spv/show13.php?file=../pano-fullscreen/climbing-tree.jpg
doesn't work correctly in Firefox 1.5 with system decimal comma?
The web site http://www.borgarvefsja.is/bvs.html does not work in Firefox 1.5 if I have Windows regional settings set to Icelandic (European style decimal symbol and list separator).  I get a popup box titled "Director Player Error" and the text "List expected for handler #duplicate".  Eventually I have to use the Task Manager to kill the Firefox process.

Works fine if they are set to English (US).  Main differences between these regional settings is that English uses . as decimal symbol but Icelandic uses , and English uses , as list separator but Icelandic uses ; and finally that English uses , as digit grouping symbol but Icelandic uses .

Works fine in Firefox 1.0.x and IE 6 regardless of regional settings => a bug in Firefox 1.5(?)

Comment 9

11 years ago
non-us locales need to get newer shockwave player per bug 321704
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 321704
You need to log in before you can comment on or make changes to this bug.