junk mails are marked as not junk from time to time in junk folder

RESOLVED DUPLICATE of bug 471682

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED DUPLICATE of bug 471682
13 years ago
9 years ago

People

(Reporter: Stefan Geisseler, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051105 Firefox/1.5
Build Identifier: version 1.5 (20051025)

sporadically most of the junk mails from a POP3 account in the junk folder are marked as not junk (right after you started up thunderbird)
Maybe only the new junk mails (the ones that came in new with the startup when you found the bug) stay marked, all others were unmarked as junk.

Reproducible: Couldn't Reproduce

Steps to Reproduce:

Actual Results:  
Most junk mails are marked not as junk in junk mail folder.

Expected Results:  
They should stay marked as junk.

Comment 1

13 years ago
Maybe related to bug 259784?
(Reporter)

Comment 2

13 years ago
It seems to be the same...
But why are all those bugs marked as duplicates of another fixed bug, which one is completely different from this one?
In addition, this one here isn't fixed.

Comment 3

12 years ago
The filter works fine and automatically marks detected spam and moves it to the junk folder.  But if I manually mark as email junk, it moves the email to junk folder but does not mark it as Junk. I have to then manually go to the junk folder and remark the email as junk in order to train my filter.  this is a consistant problem.

thunderbird
version 1.0 (20041206)

Comment 4

12 years ago
i've the opposite problem:

sometimes junk filter marks some mails as junk (i see the bin) but doesn't move to spam folder.

i can move manually or (as i do cause it's faster) i use to mark as "not junk" and remark as junk.

this happens rarely but happens!

Comment 5

12 years ago
Do you have "Trust junk mail headers set by:" turned on? 

See also:

Bugzilla Bug 323159
"Trust junk mail headers set by:" should be consistent in UI and log location/access

Comment 6

12 years ago
Created attachment 232105 [details]
screenshot

I can confirm this : sometimes, when a new message arrives in my Inbox, it is correctly detected as junk and moved to my Junk folder. But when I look in my junk folder, it is not marked as junk.

What I can see is on this kind of mail is :
* They are in the future
* They contain cyrillic characters

(see attachment)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060803 Thunderbird/3.0a1 ID:2006080303

Comment 7

12 years ago
With further observations, it seems that these two cases are causing mails not being marked as junk :

* The mail date is in the future
* The mail belongs to a thread

Comment 8

11 years ago
To Hyle and all - do you have "Trust junk mail headers set by" ON or OFF?

Comment 9

11 years ago
(In reply to comment #8)
> To Hyle and all - do you have "Trust junk mail headers set by" ON or OFF?
> 

No, trust junk mail headers is set to OFF for all my accounts
QA Contact: front-end
Reporters, does the issue still occur in the latest supported Thunderbird 2.0.0.x or trunk nightlies?

Updated

10 years ago
Assignee: mscott → nobody

Comment 11

9 years ago
I see this problem on build Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090119 Shredder/3.0b2pre. on several POP3 accounts. 'Trust junk mail headers set by' is set to OFF.

Comment 12

9 years ago
Please, take a look at this (https://bugzilla.mozilla.org/show_bug.cgi?id=471503) bug. It seems it is related to this problem someway...

Comment 13

9 years ago
The original description of this in comment 0 is bug 471682, at least as I have interpreted it. Duping, since the later bug has generated a lot more activity than this one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 471682

Comment 14

9 years ago
Cannot understand why this could be considered a duplicate of bug 471682. In any case, it's not resolved.

Tb 2.0.0.21 (20090302) on POP3 has stopped marking spam as junk but still moves
it to junk folder. It also doesn't add flag when i manually mark spam as junk,
and it has also removed all old junk flags in the folder that were there
before. It even removes flags (not immediately) when i mark messages in the
junk folder. Interestingly, Tb does add the flags when the same messages in
another folder in the same account are manually marked as junk, and the problem
does not exist in the other accounts. 

I remember having had this problem in the past (but don't remember what got rid
of it), and i remember seeing forum posts about it, but i couldn't find any bug
report besides this one, and i couldn't find any interesting forum threads.

Comment 15

9 years ago
Finally found open bug 368768
You need to log in before you can comment on or make changes to this bug.