Talkback Seamonkey Windows doesn't show symbols

RESOLVED FIXED

Status

Webtools Graveyard
Tinderbox
--
major
RESOLVED FIXED
12 years ago
4 years ago

People

(Reporter: Hermann Schwab, Assigned: Chase Phillips)

Tracking

({regression})

Details

(Reporter)

Description

12 years ago
compare Firefox TB11525931 and Seamonkey TB11523235:
Firefox shows symbols and links to LXR, Seamonkey is showing only DLL names and Offsets. This makes it pretty useless to look for dupes, search in LXR for the cause of regressions. This is going on for some days know, can't tell when it started.
(Reporter)

Comment 1

12 years ago
wfm TB11885843E MozillaTrunk Build ID	2005111308 Win98

I'll resolve this bug if I see it working in newer nightlies.
(Reporter)

Comment 2

12 years ago
had been not working in some nightlies, now working in some nightlies.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

12 years ago
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=1&searchby=stacksig&match=contains&searchfor=&vendor=All&product=MozillaTrunk&platform=Win32&buildid=&sdate=01%2F01%2F2006&stime=&edate=01%2F07%2F2006&etime=&sortby=build
671 crashes found where the Crash Date is between 01/01/2006 00:00:00 and 01/07/2006 23:59:59 and the Deployment ID looks like '%MozillaTrunkWin32%' and the sort is by Build.

MozillaOrgMozillaTrunkWin322006010309  	
MozillaOrgMozillaTrunkWin322006010209
MozillaOrgMozillaTrunkWin322005123009

are resolving the Talkback records correctly, younger builds are showing offsets into DLLs only. So I've got to install MozillaOrgMozillaTrunkWin322005123009 if I want to see what is going on, as the other builds are badly broken
Status: RESOLVED → REOPENED
Keywords: regression
Resolution: FIXED → ---

Comment 4

12 years ago
jay, is this due to the symbols foobar the other day?

Comment 5

12 years ago
Hermann:  Thanks for updating the bug on this, but the missing symbols is the result of me accidently deleting all the symbols for a few products last week.  I was able to recover symbols up to 12/22... but some of the symbols from that date until 1/05 were lost.  We are getting new symbols after that date...so builds after 1/5 should be ok for all products.

In anycase, for future reference, we are only able to keep symbols around for about a week right now... so if you don't crash with any given build within a week of the build date, there will not be symbols around to produce pretty stack traces.  I am working on increasing the storage capacity for all products to at least 1-2 months.  We do keep symbols for all major releases permanently, so crashes with releases like Firefox 1.5 and Mozilla 1.7.x should look ok.

Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

12 years ago
(In reply to comment #5)
> date until 1/05 were lost.  We are getting new symbols after that date...so
> builds after 1/5 should be ok for all products.

reopening: now symbols shown for MozillaTrunkWin32 Builds younger than MozillaOrgMozillaTrunkWin322006010309  	

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20060107 SeaMonkey/1.5a
TB13691862E

here are 260 incidents ordered acording to build ID, no functions are seen on 1st level, only offsets into dlls:

http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=1&searchby=stacksig&match=contains&searchfor=&vendor=MozillaOrg&product=MozillaTrunk&platform=Win32&buildid=&sdate=01%2F05%2F2006&stime=&edate=01%2F07%2F2006&etime=&sortby=build

about 30 crashes per BuildID:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=1&searchby=stacksig&match=contains&searchfor=&vendor=MozillaOrg&product=All&platform=All&buildid=MozillaTrunkWin322006010709&sdate=&stime=&edate=&etime=&sortby=bbid
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=1&searchby=stacksig&match=contains&searchfor=&vendor=MozillaOrg&product=All&platform=All&buildid=MozillaTrunkWin322006010609&sdate=&stime=&edate=&etime=&sortby=bbid
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=1&searchby=stacksig&match=contains&searchfor=&vendor=MozillaOrg&product=All&platform=All&buildid=MozillaTrunkWin322006010509&sdate=&stime=&edate=&etime=&sortby=bbid
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Assignee)

Comment 7

12 years ago
From today's later builds on, symbols should be present.  Reopen if this bites again.  Thanks.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED

Updated

7 years ago
Component: Tinderbox Configuration → Tinderbox
Product: mozilla.org → Webtools
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.