Miscellaneous symbols behave weird on tab label

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
6 years ago

People

(Reporter: minghong, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

Miscellaneous symbols (e.g. ☼, ♀, ♂, ☺) look funny when shown in tab labels. If the tab is active, the symbols look ok, but the color turns gray. If the tab is not active, the color is ok (black), but the symbols look broken.

Not all miscellaneous symbols are affected through. I'm not sure if it is a general problem of the XUL <tab> element. Maybe it is the problem of the Dingbat fonts in Windows?

Reproducible: Always

Steps to Reproduce:
1. View the test case
2. View the tab label
3. Focus on another tab, then view the tab label again

Actual Results:  
The miscellaneous symbols are inconsistent with other characters.

Expected Results:  
The miscellaneous symbols should be treated like other characters.
(Reporter)

Comment 1

13 years ago
Created attachment 202061 [details]
Simple test case

Comment 2

13 years ago
Confirmed
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

Status: UNCONFIRMED → NEW
Ever confirmed: true
Can you elaborate on exactly what's wrong with the symbols? The boldness seems to slightly distort them, but other than that, I see no obvious changes to them, using your testcase and the latest branch build on windows.
(Reporter)

Comment 4

13 years ago
Created attachment 203317 [details]
The actual and expected results

A picture says a thousand words.
This bug no longer occurs since we don't bold tab titles anymore.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.