Search with " " as search string gives invalid SQL query

RESOLVED DUPLICATE of bug 301232

Status

()

Bugzilla
Query/Bug List
RESOLVED DUPLICATE of bug 301232
12 years ago
12 years ago

People

(Reporter: Bernhard Merkle, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7


Entering a single space (" ") in the query give the following SQL error:

Software error:

DBD::mysql::st execute failed: Unknown column 'relevance' in 'field list' [for Statement "SELECT bugs.bug_id, bugs.bug_severity, bugs.priority, bugs.bug_status, bugs.resolution, bugs.bug_severity, bugs.priority, bugs.rep_platform, map_assigned_to.login_name, bugs.bug_status, bugs.resolution, bugs.short_desc, relevance FROM bugs  INNER JOIN profiles AS map_assigned_to ON (bugs.assigned_to = map_assigned_to.userid) LEFT JOIN bug_group_map  ON bug_group_map.bug_id = bugs.bug_id  LEFT JOIN cc ON cc.bug_id = bugs.bug_id AND cc.who = 186593 WHERE ((bugs.bug_status IN ('UNCONFIRMED','NEW','ASSIGNED','REOPENED'))) AND bugs.creation_ts IS NOT NULL AND ((bug_group_map.group_id IS NULL)    OR (bugs.reporter_accessible = 1 AND bugs.reporter = 186593)     OR (bugs.cclist_accessible = 1 AND cc.who IS NOT NULL)     OR (bugs.assigned_to = 186593) OR (bugs.qa_contact = 186593) ) GROUP BY bugs.bug_id ORDER BY relevance desc LIMIT 200"] at /opt/webtools/bugzilla/buglist.cgi line 849

For help, please send mail to the webmaster (sysadmins@mozilla.org), giving this error message and the time and date of the error. 


Reproducible: Always

Steps to Reproduce:
1. go to the search page
2. enter " " (only a blank) as search parameter
3. press find
4. error comes up

*** This bug has been marked as a duplicate of 301232 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.