Closed Bug 315366 Opened 16 years ago Closed 10 years ago

MailView/QuickSearch not applied after compacting the folder

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: bugs, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051105 Firefox/1.5
Build Identifier: version 1.5 (20051025)

see reproducible steps

Reproducible: Always

Steps to Reproduce:
1. set a view filter to see only some of your mails
2. compact the same folder

Actual Results:  
right after you've compacted the folder, you see all your mails, not only those view-filtered

Expected Results:  
the view-filter should work always
Confirmed with TB 1.5b2-1006, TB 1.6a1-1101.  Symptom is seen using MailView or QuickSearch.  Once the unfiltered list of messages is seen, if you clear QS or reset MailView to "All", the Message Pane is blanked out entirely -- no messages listed.  Subsequent attempts to refilter will show the filtered messages correctly, but returning the 'unfiltered' state shows blank.  To get past this, select another folder, then reselect the current folder.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: view filter don't work right after compact a folder → MailView/QuickSearch not applied after compacting the folder
Version: unspecified → Trunk
howdy y'all,

my tb info ...
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051201 Thunderbird/1.5 - Build ID: 2005120115

the behavior in the original post AND that in the 1st comment occur in tb 1.5-rc2.

take care,
lee

*** Bug 323598 has been marked as a duplicate of this bug. ***
QA Contact: front-end
Assignee: mscott → nobody
howdy y'all,

my tb info ...
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101207 Thunderbird/3.1.7 - Build ID: 20101207091341

i can no longer reproduce this error. i guess the rework of search in tb3.x got rid of the problem. 

i recommend closing this bug.

take care,
lee
Thanks Lee.

WFM based on comment 4, and I also can't reproduce
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.