Long SVG lines not drawn

RESOLVED DUPLICATE of bug 315383

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 315383
13 years ago
13 years ago

People

(Reporter: Paul Hopgood, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

Lines that substantially exceed the SVG view box are not shown.
It would appear coordinates are being truncated to a 16bit number somewhere as line of length less than 32767 (after any scaling) are ok but lines of 32768 or longer (after any scaling) are not shown. 

Reproducible: Always

Steps to Reproduce:
I'll attach an example file.
Actual Results:  
The attached file should display 6 horizontal lines, a pair of red, a pair of green and a pair of blue.

Expected Results:  
Only the *slightly* shorter blue lines are displayed.

The red and green lines hould be displayed.
(Reporter)

Comment 1

13 years ago
Created attachment 202082 [details]
Should draw six horizontal lines.

Comment 2

13 years ago
Go ahead and attach the testcase to bug 315382.

*** This bug has been marked as a duplicate of 315383 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.