If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Opening local xml file with stylesheet results in: Error loading stylesheet: An XSLT stylesheet does not have an XML mimetype:

VERIFIED INCOMPLETE

Status

()

Firefox
General
VERIFIED INCOMPLETE
12 years ago
7 years ago

People

(Reporter: Christian Wolfhagen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920 Firefox/1.0.7 SUSE/1.0.7-0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920 Firefox/1.0.7 SUSE/1.0.7-0.1

xml files with stylesheet linked does not display correctly, but return an error message.

Reproducible: Always

Steps to Reproduce:
1.create an xml file with stylesheet information
2.create a style sheet and save it as .xsl
3.open the xml file

Or use files attached

Actual Results:  
error message as in summary

Expected Results:  
correct rendering of the xml file

File /etc/mime.types defines xml, dtd, and xsl as text/xml

dtd are not recognised as xml files either.

Renaming the .xsl to .xml will result in correct rendering of the xml file
(Reporter)

Comment 1

12 years ago
Created attachment 202098 [details]
xml file for recreating problem
(Reporter)

Comment 2

12 years ago
Created attachment 202099 [details]
stylesheet for recreation
Your stylesheet is NOT a right XSLT... You give a renamed copy of test.xml
(Reporter)

Comment 4

12 years ago
On SuSE 9.3 (+ ?) the xsl extensions are of the mime type text/x-xslt.
This is defined in the file /usr/share/mime/packages/freedesktop.org.xml

To work around modify this file by commenting out the text/x-xslt mime-type and add <glob pattern="*.xsl"/> to the text/xml mime-type.
The run (as root) update-mime-database /usr/share/mime

This problem also exists on other Linux distributions and other UNIXes (including Solaris) and probably the workaround is (probably) similar
(Reporter)

Comment 5

12 years ago
Created attachment 202134 [details]
stylesheet for recreation of problem

Oops - but now it should be correct
Attachment #202099 - Attachment is obsolete: true

Comment 6

12 years ago
See discussion on

  https://bugs.freedesktop.org/show_bug.cgi?id=2928

Axel

Comment 7

12 years ago
This is a dupe of bug 259100. Bug 259206 seems to be fixed for Firefox 1.5. Is it not a problem anymore?
Summary: Opening xml file with stylesheet results in: Error loading stylesheet: An XSLT stylesheet does not have an XML mimetype: → Opening local xml file with stylesheet results in: Error loading stylesheet: An XSLT stylesheet does not have an XML mimetype:
No response from reporter re: comment 7 -->INCOMPLETE.
Reporter, if you still see this problem with the latest Firefox 2 please reopen this bug. Thanks!

Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.