Image is not displayed in SVG file in some circumstances

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Ruth Lang, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051025 Firefox/1.5

Hello,

in the file below the image is not displayed. It will be displayed if you remove the first embedded svg tag or if you remove the viewBox attribute in the second embedded svg tag.
Please let me know if you can't reproduce it. I will then put it on our server.
Thank you for your help.
Ruth

<?xml version="1.0" standalone="no"?>
<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" baseProfile="full">

<svg x="0" y="0" width="100" height="55">
<rect x="0" y="0" width="100" height="100" />
</svg>

<svg x="200" y="100" width="400" height="512" viewBox="0 0 1762.49 1804.02">
<image xlink:href="i1457480.jpg" x="100" y="100" width="969" height="1387" />
</svg>

</svg>

Reproducible: Always

Updated

12 years ago
Assignee: nobody → general
Component: General → SVG
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → 1.8 Branch
Created attachment 290220 [details]
testcase
This is indeed a problem in Firefox 2 (the image sometimes shows up on a refresh, but usually not), but it is no longer a problem in trunk
builds (in other words this issue will be fixed in Firefox 3). Closing as
worksforme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.