Dropdown quick key select item

RESOLVED INVALID

Status

()

Core
Layout: Form Controls
RESOLVED INVALID
12 years ago
4 years ago

People

(Reporter: mburns, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; InfoPath.1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

In application,  go to a dropdown and hit the 's' key.  Now hit the 'f' key. 
 

Reproducible: Sometimes

Steps to Reproduce:
1. In application, tab to a dropdown that contains the following list items: 'Printer', 'Router', 'Server', 'Unknown', and 'Workstation'.
2. On the keyboard hit the 'p' key and repeat for 'r', 's', 'u', and 'w'.
3. 

Actual Results:  
Sometimes the item will be selected in the dropdown and sometimes it will not change focus from previous item selected when changin from clicking 'p' to clicking 'r'.

Expected Results:  
Should always go to list item Printer if I hit the letter 'p' on the keyboard and should always go to the item Server if I hit the letter 's' on the keyboard and so forth.

Comment 1

12 years ago
What menu are you talking about? I don't see a menu that contains those items.
(Reporter)

Comment 2

12 years ago
Created attachment 202245 [details]
This is a dropdown from a customized application.

Sorry I forgot to mention this is from a customized application.  The quick key access works as should in IE but not Firefox, (which btw, i prefer to use).  I am a QA tester and I am required to test the application in both IE and Firefox.  The developer is claiming this to be a Firefox bug, not his own.  Is this correct?

Comment 3

12 years ago
Could you attach a minimized testcase showing the problem?
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> Could you attach a minimized testcase showing the problem?

What information do you need in the test case, so I can provide you with the exact details you need.

Comment 5

12 years ago
(In reply to comment #4)
> What information do you need in the test case, so I can provide you with the
> exact details you need.

Well, the HTML that's causing the problem, if possible. 
(Reporter)

Comment 6

12 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > What information do you need in the test case, so I can provide you with the
> > exact details you need.
> Well, the HTML that's causing the problem, if possible. 

It's a Simple drop-down box (a selectable list) and when i tab to the dropdown and select a letter on the keyboard (first letter of one of the list items) it only goes to that list item sometimes, not every time.

<html>
<body>

<form>
<select name="asset type">
<option value="printer">Printer
<option value="router">Router
<option value="server">Server
<option value="Unknown">Unknown
<option value="Workstation">Workstation
</select>
</form>

</body>
</html>


Comment 7

12 years ago
Hrm... this is sort of buggy.
Whiteboard: DUPEME
Version: unspecified → Trunk

Comment 8

12 years ago
Created attachment 202422 [details]
testcase

Updated

12 years ago
Keywords: testcase

Comment 9

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051109 Firefox/1.6a1

It seems to get stuck if you type one letter two times in succession; e.g. pressing "p" twice and then pressing "w" will not take you to Workstation.

Comment 10

12 years ago
Created attachment 202428 [details]
testcase
Attachment #202422 - Attachment is obsolete: true

Comment 11

12 years ago
I was unable to find a duplicate for this bug (after over 30min of searching).  Although, it appears you are moving too fast for type ahead.  So you type "w" twice and then type "u" for unknown, you're acualy looking for "wu" according to type ahead, which isn't there, so it ignores you.
Component: Menus → Keyboard Navigation

Comment 12

12 years ago
I have found the same behavior in my own Firefox web app. The selection for large dropdown lists is inconsistent. Sometimes, it jumps to the right location, and then won't jump back (from S to H, for example). Sometimes, it won't jump down the list at all, but merely changes the field in select box itself, leaving the dropdown menu open.

I can provide a test case, but the bug appears to be inconsistently reproducible. It happens enough that the customers using my web app are complaining...so here I am!

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: Keyboard Navigation → Layout: Form Controls
Product: Firefox → Core
QA Contact: menus → layout.form-controls
All you're seeing is that if you type letters in fast sequence we select the first entry that starts with that string.  It's pretty obvious if you put multiple entries with the same initial letter in the dropdown.

This is by-design.  And yes, it's a dup.  But finding the original is just not worth the effort...
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.