User List should have "don't show disabled users" option

RESOLVED FIXED in Bugzilla 4.4

Status

()

--
enhancement
RESOLVED FIXED
13 years ago
6 years ago

People

(Reporter: jhg, Assigned: timello)

Tracking

unspecified
Bugzilla 4.4
Bug Flags:
approval +

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

The user list page editusers.cgi?action=list would benefit greatly
from a "don't show disabled users" checkbox so that one could work
with only current users in the list when desired.

Reproducible: Always

Steps to Reproduce:

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

7 years ago
Assignee: user-accounts → administration
Component: User Accounts → Administration
(Assignee)

Updated

7 years ago
Duplicate of this bug: 689788
(Assignee)

Comment 2

7 years ago
Created attachment 562908 [details] [diff] [review]
v1

A checkbox for "enabled users only" that was checked by default.
Assignee: administration → timello
Status: NEW → ASSIGNED
Attachment #562908 - Flags: review?(glob)
Comment on attachment 562908 [details] [diff] [review]
v1

r=glob with the following fixed on commit:

>+  <input type="checkbox" name="enabledonly" value="1" id="enabledonly" checked />

we don't serve xhtml, you don't need to close the input element.
Attachment #562908 - Flags: review?(glob) → review+
Flags: approval?

Comment 4

7 years ago
Comment on attachment 562908 [details] [diff] [review]
v1

>=== modified file 'editusers.cgi'

>+        if ($enabled_only eq '1') {
>+            $query .= " $nextCondition profiles.is_enabled = 1 ";
>+        }

Please set nextCondition = 'AND' if this code is triggered, in case future code is added. This was not needed for |if ($grouprestrict eq '1')| only because this check was already done earlier in the code.



>=== modified file 'template/en/default/admin/users/search.html.tmpl'

>+  <input type="checkbox" name="enabledonly" value="1" id="enabledonly" checked />

enabled_only would be more readable + what glob said about XHTML.


>+  <label for="enabledonly">Enabled users only</label>

"Enabled user accounts only" would be more accurate.
(Assignee)

Comment 5

7 years ago
Created attachment 563121 [details] [diff] [review]
v2
Attachment #562908 - Attachment is obsolete: true
Attachment #563121 - Flags: review?(LpSolit)
(Assignee)

Updated

7 years ago
Attachment #563121 - Flags: review?(LpSolit) → review?(glob)
Comment on attachment 563121 [details] [diff] [review]
v2

r=glob :)
Attachment #563121 - Flags: review?(glob) → review+

Comment 7

7 years ago
Comment on attachment 563121 [details] [diff] [review]
v2

>=== modified file 'template/en/default/admin/users/search.html.tmpl'

>+  <input type="checkbox" name="enabled_only" value="1" id="enabled_only" checked>

On checkin, please write checked="checked" (as we do elsewhere in the code).

Updated

7 years ago
Flags: approval? → approval+
Target Milestone: --- → Bugzilla 5.0
(Assignee)

Comment 8

7 years ago
Committing to: bzr+ssh://timello%40gmail.com@bzr.mozilla.org/bugzilla/trunk/                                                                                                           
modified editusers.cgi
modified template/en/default/admin/users/search.html.tmpl
Committed revision 7970.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Keywords: relnote

Comment 9

6 years ago
Added to relnotes for 4.4.
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.