If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

freezes when I click a subfolder in the Bookmarks Toolbar Folder for the second time

RESOLVED DUPLICATE of bug 298502

Status

()

Firefox
Bookmarks & History
--
critical
RESOLVED DUPLICATE of bug 298502
12 years ago
12 years ago

People

(Reporter: David, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: http://download.mozilla.org/?product=firefox-1.5rc1&os=osx&lang=en-US

This bug only occurs with Firefox 1.5 Beta 1 through Firefox RC 1. It does not occur in 1.0.7. I am using Mac OS X Jaguar (10.2.8). Whenever I click a subfolder in the Bookmarks Toolbar Folder (from the main screen as opposed to the Bookmark Manager) for the second time while Firefox is opened, Firefox freezes and the Mac OS X swirly-beachball-cursor spins.

Reproducible: Always

Steps to Reproduce:
1. Create a subfolder in the Bookmarks Toolbar Folder and put some bookmarks in there.
2. Quit Firefox (I don't know if this is necessary since I am not using RC1 anymore, but I might as well include this in case it is necessary to reproduce the bug).
3. Click on the subfolder in the Bookmarks Toolbar Folder from the main screen, and click out of it once the folder's contents drop down.
4. Repeat step 3 and Firefox will freeze.
Actual Results:  
The cursor turns into the Mac OS X beachball and spins indefinitely.

Expected Results:  
The subfolder's contents should have just dropped down like normal.

Only occurs in the beta versions and Firefox RC 1, and I do not know if the problemn occurs on platforms other than Mac OS X Jaguar (10.2.8). This bug will not occur in the stable release (currently 1.0.7).

Comment 1

12 years ago
On Windows, WFM.

*** This bug has been marked as a duplicate of 312111 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 298502 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.