page elements reposition or flicker

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
14 years ago
9 months ago

People

(Reporter: annand.mark, Assigned: roc)

Tracking

({testcase})

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8) Gecko/20051025 Firefox/1.5

Selecting menu items, the menu display appears unsteady as there appears to be a 1 pixel layout error that's immediately corrected by a screen redraw

Reproducible: Always

Steps to Reproduce:
1. Select several menu items from the menu at left one after another
2. Observe boundary of menu, and menu items, for movement


Actual Results:  
Page objects in menu are unsteady as they reposition themselves slightly when the pages load

Expected Results:  
Menu appears steady - Firefox 1.07 and previous handles this ok.
Reporter

Comment 1

14 years ago
Windows only? I've checked this bug using Firefox 1.5 RC1 on a Mac, and that seems OK

Regressed in the last month or so? I've checked it against a Firefox beta 1 build from 06/09/2005 on Windows XP, and this behaviour isn't present in that build.

Not just me? I can reproduce it on a different machine running Windows XP and again Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8) Gecko/20051025 Firefox/1.5 and a CRT monitor. (The machine from which I reported the bug has a flat screen).

Reporter

Comment 2

14 years ago
Reduced test case at:

http://it-help.bathspa.ac.uk/testcase_315519.html

css for left-hand menu is this:

div.nav        {  position: fixed;  }
div.nav ul     {  padding-left: 0em; }
div.nav li     {  display: block; }

html is this:

<body>

<div class="nav">

<ul>
<li><a href="testcase_315519.html" class="current">&nbsp;Home&nbsp;Page</a></li>
</ul>

</div>

<p style="margin-left: 9em">Select menu item at left. The item ideally shouldn't twitch horizontally ...</p>

</body>
</html>
Keywords: testcase
Assignee: nobody → roc
Component: Layout: Block and Inline → Layout: View Rendering
QA Contact: layout.block-and-inline → ian
I have a hard time seeing the bug with the testcase, but I think this is WFM in my debug build that has the "frame display lists" patch in it (bug 317375).
Please test again when that bug becomes fixed.
Depends on: 317375
This should be fixed now that bug 317375 is fixed.
Mark, please test with the latest nightly trunk build that has the patch in?

Comment 5

13 years ago
The testcase is not very useful IMO.
No response from the reporter to questions. 
I am marking this fixed since there is no flicker when using Firefox 1.5.0.2 rv: 1.8.0.2 build 20060410 or a recent 1.8 branch nightly. 

For trunk builds, there is still bug 324819.

> 1. Select several menu items from the menu at left one after another
> 2. Observe boundary of menu, and menu items, for movement
This looks more to be one of the outline bugs; see bug 261196.

Resolving as FIXED by bug 317375

Comment 6

13 years ago
Now resolving (I forgot to do it before).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.