Last Comment Bug 315525 - Document new tab behaviour under Win when starting SM with an instance already running
: Document new tab behaviour under Win when starting SM with an instance alread...
Status: RESOLVED FIXED
: fixed1.8
Product: SeaMonkey
Classification: Client Software
Component: Help Documentation (show other bugs)
: unspecified
: x86 Windows XP
: -- trivial (vote)
: ---
Assigned To: Giacomo Magnini
: Daniel Wang
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-08 02:06 PST by Giacomo Magnini
Modified: 2005-12-22 05:36 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch as suggested by Neil on IRC. Not sure if using a class="win" will show also for OS/2, which has the same behaviour. (1.46 KB, patch)
2005-11-08 02:08 PST, Giacomo Magnini
iann_bugzilla: review-
Details | Diff | Splinter Review
Verified under Win that the preference in question was "Links from other applications" (1.48 KB, patch)
2005-11-15 07:40 PST, Giacomo Magnini
iann_bugzilla: review-
Details | Diff | Splinter Review
Is this any better? (1.75 KB, patch)
2005-12-09 02:38 PST, Giacomo Magnini
iann_bugzilla: review-
Details | Diff | Splinter Review
Another attempt. (Checked in to trunk/branch) (1.84 KB, patch)
2005-12-11 02:08 PST, Giacomo Magnini
iann_bugzilla: review+
iann_bugzilla: approval‑seamonkey1.0+
Details | Diff | Splinter Review
Follow up patch. Will need this also on branch (checked in to trunk/branch). (1.73 KB, patch)
2005-12-17 23:54 PST, Giacomo Magnini
iann_bugzilla: review+
iann_bugzilla: approval‑seamonkey1.0+
Details | Diff | Splinter Review

Description Giacomo Magnini 2005-11-08 02:06:25 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7
Build Identifier: 

As a reference, see bug 310803.

Reproducible: Always

Steps to Reproduce:




Patch coming after some discussion on IRC with Neil.
Comment 1 Giacomo Magnini 2005-11-08 02:08:48 PST
Created attachment 202222 [details] [diff] [review]
Patch as suggested by Neil on IRC. Not sure if using a class="win" will show also for OS/2, which has the same behaviour.
Comment 2 Giacomo Magnini 2005-11-08 02:48:59 PST
Comment on attachment 202222 [details] [diff] [review]
Patch as suggested by Neil on IRC. Not sure if using a class="win" will show also for OS/2, which has the same behaviour.

Ok, class="win" will work on OS/2, too.
Comment 3 Stefan [:stefanh] 2005-11-10 07:43:37 PST
Comment on attachment 202222 [details] [diff] [review]
Patch as suggested by Neil on IRC. Not sure if using a class="win" will show also for OS/2, which has the same behaviour.

+<p>&brandShortName

You forgot the ";" ;)
Comment 4 Giacomo Magnini 2005-11-11 00:18:48 PST
(In reply to comment #3)
> You forgot the ";" ;)

Twice! A 100% error ratio! ;) Fixed locally.
Comment 5 Ian Neal 2005-11-14 15:50:23 PST
(In reply to comment #4)
> (In reply to comment #3)
> > You forgot the ";" ;)
> 
> Twice! A 100% error ratio! ;) Fixed locally.
> 

I count three! :-P
Comment 6 Ian Neal 2005-11-14 15:58:19 PST
Comment on attachment 202222 [details] [diff] [review]
Patch as suggested by Neil on IRC. Not sure if using a class="win" will show also for OS/2, which has the same behaviour.

>Index: extensions/help/resources/locale/en-US/cs_nav_prefs_navigator.xhtml
>===================================================================
>+<div class="win">
>+<p>&brandShortName will also use your external link preference to determine
>+  where to load your home page if you try to open &brandShortName while it is
>+  already open.</p>
Missing ; twice. Is it worth pointing out where in the preferences you change your "external link preference"? I do not currently see a preference with this name.

>+
>+<p>To ensure that &brandShortName opens a new window, select the Navigator
>+  option in <a href= "cs_nav_prefs_appearance.xhtml#appearance>Appearance
>+  Preferences - Appearance</a>.</p>
>+</div>
>+
Missing ; again.
Comment 7 Giacomo Magnini 2005-11-15 02:18:57 PST
(In reply to comment #5)
> I count three! :-P

Ouch! :)
Comment 8 Giacomo Magnini 2005-11-15 07:40:48 PST
Created attachment 203126 [details] [diff] [review]
Verified under Win that the preference in question was "Links from other applications"
Comment 9 Ian Neal 2005-11-20 14:15:23 PST
I cannot reproduce the behaviour you are commenting on. I have a browser window open and my "Links from other applications" set to new tab in the current window but when i click on SM it opens a new window not a new tab. I get a similar issue with current tab/window option.
Comment 10 Ian Neal 2005-11-21 05:32:47 PST
Comment on attachment 203126 [details] [diff] [review]
Verified under Win that the preference in question was "Links from other applications"

>Index: extensions/help/resources/locale/en-US/cs_nav_prefs_navigator.xhtml
>===================================================================
>RCS file: /cvsroot/mozilla/extensions/help/resources/locale/en-US/cs_nav_prefs_navigator.xhtml,v
>retrieving revision 1.30
>diff -u -8 -p -r1.30 cs_nav_prefs_navigator.xhtml
>--- extensions/help/resources/locale/en-US/cs_nav_prefs_navigator.xhtml	6 Nov 2005 22:21:19 -0000	1.30
>+++ extensions/help/resources/locale/en-US/cs_nav_prefs_navigator.xhtml	15 Nov 2005 15:39:45 -0000
>@@ -474,16 +474,26 @@
>       <li><strong>A new tab in the current window</strong>: Open the linked
>         page in a new tab instead of a new window.</li>
>       <li><strong>A new window</strong>: Open the linked page in a new window.
>         (This is the default).</li>
>     </ul>
>   </li>
> </ul>
> 
>+<div class="win">
>+<p>&brandShortName; will also use your Links from other applications preference
>+  to determine where to load your home page if you try to open &brandShortName;
>+  while it is already open.</p>
From what Neil explained to me on IRC, it is not as simple as this:

Neil	when you launch mozilla, it opens windows based on command-line parameters, if there are any
Neil	if none of your command-line parameters open windows, it then looks at your appearance preferences (trunk only - this step is skipped on branch if you have any parameters whether or not they open windows)
Neil	if you have no appearence preferences either, then if you have a home page group then that gets opened in a new window
Neil	otherwise if you have a single home page then it follows your external link preference
Neil	(again, branch always opens the home page in a new window)

I would say the minimum you need to mention is about "Links from other applications" only being effective if you don't have a group of pages as you homepage AND you have no appearance prefs set.
Comment 11 Giacomo Magnini 2005-12-09 02:38:21 PST
Created attachment 205387 [details] [diff] [review]
Is this any better?
Comment 12 Ian Neal 2005-12-10 17:55:52 PST
Comment on attachment 205387 [details] [diff] [review]
Is this any better?

>Index: extensions/help/resources/locale/en-US/cs_nav_prefs_navigator.xhtml
>===================================================================
>+<div class="win">
>+  <p>To ensure that &brandShortName; opens a new window, select the Navigator
>+    option in <a href= "cs_nav_prefs_appearance.xhtml#appearance>Appearance
>+    Preferences - Appearance</a>.</p>
>+
>+  <p>If you want &brandShortName; to open a new tab instead of a new window when
>+    you launch it and it is already running, ensure the following:
>+
>+  <ul>
>+    <li>If you launch &brandShortName; by command line, do not use command-line
>+      parameters that open windows.</li>
>+    <li>Set the Navigator option only, as described above.</li>
As far as I am aware, from testing, you have to make sure nothing is checked in the appearance preference.

>+    <li>Set Links from other applications preference to A new tab in the current
>+      window.</li>

Do we not put quotes round a preference value or something similar?
Comment 13 Giacomo Magnini 2005-12-11 02:08:36 PST
Created attachment 205539 [details] [diff] [review]
Another attempt. (Checked in to trunk/branch)

- Used <q></q> around options
- Modified to nothing checked in Appearance
Comment 14 Stefan [:stefanh] 2005-12-14 11:37:05 PST
Checked in (trunk/branch) by Standard8.
Comment 15 Hasse 2005-12-17 11:19:52 PST
Comment on attachment 205539 [details] [diff] [review]
Another attempt. (Checked in to trunk/branch)

The XML parser doesn't like this new version.

>+<div class="win">
>+  <p>To ensure that &brandShortName; opens a new window, select the Navigator
>+    option in <a href= "cs_nav_prefs_appearance.xhtml#appearance>Appearance
>+    Preferences - Appearance</a>.</p>

You need a " after "cs_nav_prefs_appearance.xhtml#appearance

>+  <p>If you want &brandShortName; to open a new tab instead of a new window when
>+    you launch it and it is already running, ensure the following:

You need to close this paragraph either here or after the <ul>.

>+  <ul>
>+    <li>If you launch &brandShortName; by command line, do not use command-line
>+      parameters that open windows.</li>
>+    <li>Nothing is set in the
>+      <a href= "cs_nav_prefs_appearance.xhtml#appearance>Appearance Preferences
>+      - Appearance</a>.</li>

You need a " after "cs_nav_prefs_appearance.xhtml#appearance
Comment 16 Giacomo Magnini 2005-12-17 23:54:06 PST
Created attachment 206228 [details] [diff] [review]
Follow up patch. Will need this also on branch (checked in to trunk/branch).
Comment 17 Karsten Düsterloh 2005-12-18 07:27:08 PST
Comment on attachment 206228 [details] [diff] [review]
Follow up patch. Will need this also on branch (checked in to trunk/branch).

Checked in on trunk and MOZILLA_1_8_BRANCH with a=SeaMonkey Council over IRC.
Comment 18 Karsten Düsterloh 2005-12-22 05:36:42 PST
Checked in on MOZILLA_1_8_0_BRANCH.

Note You need to log in before you can comment on or make changes to this bug.