If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Ctrl + pgup or pgdown to switch tabs doesn't work in an input field

VERIFIED DUPLICATE of bug 290177

Status

()

Firefox
Tabbed Browser
--
major
VERIFIED DUPLICATE of bug 290177
12 years ago
12 years ago

People

(Reporter: Luca M., Unassigned)

Tracking

({regression})

1.5.0.x Branch
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5

as subject, Ctrl + pgup or pgdown  doesn't work if the cursor is in a textfield.

This worked on firefox 1.0.7 and not anymore on firefox 1.5

Reproducible: Always

Steps to Reproduce:
1. www.google.com
2. press CTRL + PGUP

Actual Results:  
doesn't switch between tabs

Expected Results:  
switch between tabs

Comment 1

12 years ago
Was fixed in bug 232770 for the location bar.

Confirmed in Firefox 1.5 RC1 on Windows XP. The autocompletion pops up and prevents the tab-swtiching.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: DUPEME
(Reporter)

Comment 2

12 years ago
what's that "DUPEME" ?

Comment 3

12 years ago
An indication that reminds us that it might still be a duplicate of an existing bug, but I didn't find it (except some older ones that were already duped to bug 232770).
(Reporter)

Comment 4

12 years ago
That bug 232770 titles: Tab-switching shortcuts don't work when address bar has focus (Ctrl+Tab, Ctrl+PgDn)

it is referring to address bar.

I'm referring to textboxes.

You can test in this page ... for example, go in "Keywords" and try to press CTRL+PGUP and it does not work...

but if you are in "Additional Comments" it works!!!!

Updated

12 years ago
Keywords: regression
Summary: Ctrl + pgup or pgdown doesn't work in a textfield → Ctrl + pgup or pgdown to switch tabs doesn't work in an input field
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5 Branch
I tried it out, opened www.google.com in an extra tab, put the cursor in the inputfield, and all that I can say is that ctrl+pg.up or ctrl+pg.down mostly doesn't work.
On this page, when I click in this Additional Comments box and hit ctrl+pg.up or ctrl+pg.down it always goes to the other tab.
It seems to have regressed between 21-2-2005 and 2-3-2005 so big chance that this is a dupe. 

*** This bug has been marked as a duplicate of 210435 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

12 years ago
Excuse me, Steve: I don't agree you mark this bug as dupe of that bug that is  RESOLVED WONTFIX.

Tab switching is a Firefox feature and it should work by keyboard *everytime*.

On Firefox 1.0.7 it works perfectly, on 1.5 it's *broken*.

The completion list of text field, can be also invoked with "down" arrow.

Tab switching is extremly useful if you want to write in a tab things from another tab.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 8

12 years ago
Luca, please use CTRL+TAB instead of CTRL+PGDN and CTRL+SHIFT+TAB instead of CTRL+PGUP.  This bug is a duplicate of another bug, please do not reopen it.

As a workaround, turn off form autocomplete (Tools -> Options -> Privacy -> Save Forms > uncheck) if you really want CTRL+PGUP and CTRL+PGDN to work in textboxes.  I believe this feature was 'removed' for IE parody.

*** This bug has been marked as a duplicate of 290177 ***
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Whiteboard: DUPEME

Comment 9

12 years ago
This was a frequently used feature in a previous release.  How can you just say "please use ..." instead?  And why?  I beleive that this shortcut for switching using ctrl+pgup and ctrl+pgdn was adverties as an added feature in one of the earlier Firefox release notes.  I've been using it for ages.  It still works in some cases.  This is clearly a bug introduced in 1.5

(In reply to comment #8)
> Luca, please use CTRL+TAB instead of CTRL+PGDN and CTRL+SHIFT+TAB instead of
> CTRL+PGUP.  This bug is a duplicate of another bug, please do not reopen it.
> 
> As a workaround, turn off form autocomplete (Tools -> Options -> Privacy ->
> Save Forms > uncheck) if you really want CTRL+PGUP and CTRL+PGDN to work in
> textboxes.  I believe this feature was 'removed' for IE parody.
> 
> *** This bug has been marked as a duplicate of 290177 ***
> 

You need to log in before you can comment on or make changes to this bug.