All users were logged out of Bugzilla on October 13th, 2018

DBD::Pg::db do failed: ERROR: invalid byte sequence for encoding "UNICODE": 0xe7e36f

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
8 years ago

People

(Reporter: smistura, Unassigned)

Tracking

2.20
x86
Windows XP

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; FDM)
Build Identifier: DBD::Pg::db do failed: ERROR:  invalid byte sequence for encoding "UNICODE": 0xe7e36f

Software error:
DBD::Pg::db do failed: ERROR:  invalid byte sequence for encoding "UNICODE": 0xe7e36f
 [for Statement "INSERT INTO longdescs
                      (bug_id, who, bug_when, thetext, isprivate, work_time)
               VALUES (?,?,?,?,?,?)"] at Bugzilla/Bug.pm line 720
	Bugzilla::Bug::AppendComment(2, 2, 'Teste de Acentua\x{e7}\x{e3}o', 'undef', '2005-11-08 08:08:18.328-03', 'undef') called at G:/Bugzilla/process_bug.cgi line 1369


Reproducible: Always




DBD::Pg::db do failed: ERROR:  invalid byte sequence for encoding "UNICODE": 0xe7e36f
 [for Statement "INSERT INTO longdescs
                      (bug_id, who, bug_when, thetext, isprivate, work_time)
               VALUES (?,?,?,?,?,?)"] at Bugzilla/Bug.pm line 720
	Bugzilla::Bug::AppendComment(2, 2, 'Teste de Acentua\x{e7}\x{e3}o', 'undef', '2005-11-08 08:08:18.328-03', 'undef') called at G:/Bugzilla/process_bug.cgi line 1369

Comment 1

13 years ago
Several questions :

What version of PostgreSQL are you using?
What version of Bugzilla are you using?

Are the two characters that you are trying to insert a a c with a cedilla and
an a with a tilde ?
Blocks: 314490
(Reporter)

Comment 2

13 years ago
Answering the Questions:

- What version of PostgreSQL are you using?
R: 8.0

- What version of Bugzilla are you using?
R: Version 2.20 

- Are the two characters that you are trying to insert a a c with a cedilla and
  an a with a tilde ?
R: Any caracter accented this problem is happening.

Comment 3

13 years ago
(In reply to comment #2)
> 
> R: Any caracter accented this problem is happening.

Interesting. I can't reproduce this using the same version of PostgreSQL and the same version of Bugzilla (on Linux).

Updated

13 years ago
Version: unspecified → 2.20
(Reporter)

Comment 4

13 years ago
I carried through a test, I made a manual INSERT with the accented characters and inserted normally.

Comment 5

13 years ago
Could you make the changes as documented at: http://www.bugzilla.org/docs/2.20/html/security-bugzilla.html

then try again using bugzilla

Comment 6

13 years ago
Sidnei: What version of DBD::Pg and DBI are you using?

When you look at the database list (the "\l" command) in the psql client, what "encoding" does the Bugzilla database have?
(Reporter)

Comment 7

13 years ago
(In reply to comment #5)
> Could you make the changes as documented at:
> http://www.bugzilla.org/docs/2.20/html/security-bugzilla.html
> 
> then try again using bugzilla
> 

Ok, with these alterations functioned legal, is thankful.

Comment 8

12 years ago
(In reply to comment #7)
>
> Ok, with these alterations functioned legal, is thankful.

This indicates that Pg doesn't accept non-UTF-8 text if the database has been created with that encoding. This reads more like a documentation bug (you should force the charset if you're using Pg as a database) more than anything else. Any objections to my changing the component (and filing a patch) ?

Comment 9

8 years ago
Bugzilla now encodes everything using UTF8 by default.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.