SMTP (send) and POP (biff/fetch) fail after product has run for several hours

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: escoles, Assigned: Scott MacGregor)

Tracking

PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Mac_PowerPC Mac OS X; en) Opera 8.5
Build Identifier: Thunderbird 1.5b2 (20051006)

After TB has been running for several hours (time required varies -- see below), it will no longer fetch or send mail. When attempting to fetch, it shows "Connected to [server name]..." in the status bar, and eventually failes with an error message. Similarly, an attempt to send at this point will result in the send operation timing out. 

(Note that it's difficult to provide exact error messages since this problem occurs only after several hours of operation.)

Steps to resolve: 

1. Quit application. 
2. Restart application. 
3. SMTP / POP operations occur normally.

Note: I have observed this behavior on Thunderbird and the Moz Mail component on Windows, Linux and OS X for every version I have used (starting in 2002). 



Reproducible: Always

Steps to Reproduce:
1. Run software for several hours. (time required varies with factors I haven't been able to determine.)
2. Click "Get Mail" or attempt to send a message
3. Operation will time out. 

Actual Results:  
Operations time out.

Expected Results:  
Mail is sent / retrieved.

ADDITIONAL BEHAVIOR OBSERVED WITH TB 1.5b2: When terminating the program, the error message "Unable to complete request because a secure connection could not be cleaned up." (May not have exact wording on that.)

My apologies -- I believe this has been reported in the past, but I wasn't able to find the older bug -- my recollection is that it was opened in '01 and has been closed and re-opened several times since -- with about 45 minutes of searching, and I need to get back to work. My recollection is that it was a bug in the networking layer that was half-fixed at one point and then rolled back. Since this has been hanging out there for years, I'll leave it at "normal".
(Reporter)

Updated

13 years ago
Version: unspecified → 1.5

Comment 1

13 years ago
Can you try a 1.6a1 nightly build from today? This sounds like bug 173924 for which I checked in a fix late on 11/04. Warning, nightly builds can be a bit unstable though I think today's build should be OK as long as the fix for bug 315453 made it into the build.

The other thing to try is to hit the offline button twice when you get into this situation, i.e., go offline and back online immediately. This makes the network service cleanup and release the leaked resources.
(Reporter)

Comment 2

13 years ago
Sorry for the delay; as the problem takes several hours to a day to manifest, and I flubbed the first test, I needed to wait for it to manifest again. 

Two points: 

1 - Bug 173924 is definitely the same as the one i recall from before; I backed up my mailstore and am trying the latest nightly (1.6a1) and will report back. If it works after 1.6a1, I'll take the liberty of changing resoltuion to 'fixed' unless that's not cool. Leaving as 'unconfirmed' for now.

2 - Toggling the offline state does allow POP and SMTP to start working again. The first time I tried this, I got the 'secure connection' error the next time I shut down TB, so I wanted to run the test again; I did not get it the second time. My working hypothesis is that I had allowed enough time or network activity to elapse that the network problems were manifesting again. 

Comment 3

13 years ago
If it works in 1.6a1, can you resolve it as a dup of bug 173924 ? Thx!
WFM on Thunderbird version 2.0.0.12 (20080213), the latest supported version.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.