Closed Bug 315609 Opened 16 years ago Closed 14 years ago

Display something other than a blank window when no extensions are installed.

Categories

(Toolkit :: Add-ons Manager, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.9beta5

People

(Reporter: dsimcha, Assigned: mossop)

Details

Attachments

(1 file)

958 bytes, patch
robert.strong.bugs
: review+
beltzner
: approval1.9+
Details | Diff | Splinter Review
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051024 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051024 Firefox/1.5

When the extension manager in Mozilla Firefox is opened and no extensions are installed, something other than the standard empty window should appear.  Although this obviously doesn't indicate that anything is broken, it might seem it to the average user.  Some nice text explaining what extensions are and providing a link to the Mozilla Update site might be a good replacement, since from feedback I've been receiving from friends, it seems like very few people use extensions.

Reproducible: Always

Steps to Reproduce:
1.  Start Firefox with a profile with no extensions installed
2.  Open Extension Manager.
3.

Actual Results:  
Extension Manager has no text informing the novice user who has no extensions installed of what an extension is.  All that is present is a window with a white background and the standard buttons at the bottom.

Expected Results:  
The software should display a message describing what an extension is and linking to Mozilla Update if no extensions are installed.
Severity: trivial → enhancement
beltzner, what do you think? I am unsure if there is value in this since we will be installing talkback by default in 2.0 but it is a good idea.
Well, we have a link to Mozilla Update in the bottom right corner ("Get Extensions") but it's somewhat invisible and I remember filing a bug a while back to get that swapped in for the current "Install ...".

I'm rambling. :)

Something like:

"Extensions allow you to customize your browser and extend its capabilities. Visit Mozilla Add-Ons to get your first extension!"

would be good, but it wouldn't be a blocker, especially if we're shipping Talkback by deafult in Firefox 2.
Sounds good to me and this would be for Firefox 3.0 if we do it at all... we'll know better after people start using Firefox 2.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached patch patchSplinter Review
This was actually meant to happen in bug 404024 but I missed it. This makes the default first open view of the addons manager the Get Add-ons pane which I believe would fix this bug.
Assignee: nobody → dtownsend
Status: NEW → ASSIGNED
Attachment #307210 - Flags: review?(robert.bugzilla)
Whiteboard: [has patch]
Attachment #307210 - Flags: review?(robert.bugzilla) → review+
Comment on attachment 307210 [details] [diff] [review]
patch

Simple patch that just changes the default view for the add-ons manager.
Attachment #307210 - Flags: approval1.9?
Comment on attachment 307210 [details] [diff] [review]
patch

a1.9=beltzner
Attachment #307210 - Flags: approval1.9? → approval1.9+
Checking in toolkit/mozapps/extensions/content/extensions.js;
/cvsroot/mozilla/toolkit/mozapps/extensions/content/extensions.js,v  <--  extensions.js
new revision: 1.164; previous revision: 1.163
done
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Whiteboard: [has patch]
Target Milestone: --- → Firefox 3 beta5
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.