When wmode is used, the flash object delays loading until scrolled on the screen

RESOLVED DUPLICATE of bug 266933

Status

()

RESOLVED DUPLICATE of bug 266933
13 years ago
13 years ago

People

(Reporter: woody, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

I'm using the satay method to display the flash object, but the problem also exists when using embed.

In the following test page:

Test case #1
http://www.kayaktrips.net/wmode.html

The flash object either does not load, or fails to start until it is scrolled onto the screen (scroll down in the test page and the scroll will pause when the swf scrolls onto the screen untilwhile it loads.

The following example is the same, except the wmode parameter is not included. When you scroll down you will see the flash object is already loaded (no delay)

Test case #2
http://www.kayaktrips.net/nowmode.html



Reproducible: Always

Steps to Reproduce:
1. Load test pages
2. Scroll down

Actual Results:  
In test case #1, the scroll pauses while the flash object loads.
In test case #2, the flash object is already loaded when you scroll down.

Expected Results:  
Test case #2 is the correct behavior whether wmode is used or not.
(Reporter)

Comment 1

13 years ago
Forgot to mention - using Flash plugin version 8.

Comment 2

13 years ago
Duplicate of/related to Core bug 266933?
(Reporter)

Comment 3

13 years ago
Yes, I believe it is, but the system would not let me re-open it.

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 266933 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.