Underlining of superscripted links: <a ...>Some<sup>thing</sup></a>

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: jdawiseman, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

When parsing HTML such as <a ...>Something<sup>something</sup></a>, the underline is not continuous, but is rendered superscript in the superscripted bit. That would be fine with <sup><a ...>something</a></sup>, but with the <a> outside it would look much tidier if the link had a single continuous joined-up underline, even if that traverses a <sup>...</sup>.

Or maybe it's low-priority mess with which one just has to live.

Reproducible: Always
Make sure you give a strict DOCTYPE at the top of your document, e.g.:

   <!DOCTYPE HTML>

...or:

   <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN">

This will fix the rendering. (If it doesn't, reopen this bug and attach a testcase showing the problem.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Component: General → Layout: Fonts and Text
Product: Firefox → Core
Resolution: --- → WORKSFORME
Version: unspecified → Trunk
(Reporter)

Comment 2

13 years ago
Beautiful! Apologies for having wasted your time.
No problem. For what it's worth, the reason we do things the broken way when there isn't a DOCTYPE (or when it's a particular one from a list we have) is that a lot of old pages actually depend on the old rendering (believe it or not).
(Reporter)

Comment 4

13 years ago
My website hasn't been making use of DOCTYPE, mostly because I dislike adding stuff that I don't understand and appears to be redundant. Time to mend my ways. Thank you again. 
You need to log in before you can comment on or make changes to this bug.