Saving an attachment while viewing it saves the entire e-mail

RESOLVED DUPLICATE of bug 270772

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 270772
13 years ago
13 years ago

People

(Reporter: Sterling Stein, Unassigned)

Tracking

1.7 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051001
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051001

If you are viewing an attachment in an e-mail from the browser
(not e-mail part), for example with file:///email.eml?part=1.2
and do Save As or even "Save Image As...", it will save the entire
e-mail, and not just the attachment.

Reproducible: Always

Steps to Reproduce:
1. Save e-mail as .eml
2. Go to an attachment of it (file:///email.eml?part=1.2)
3. Do "Save Image As..."

Actual Results:  
The entire e-mail is saved to the specified file.

Expected Results:  
The specific attachment is saved.

This area in general seems a bit buggy.
For example, the e-mail had trouble accessing its own attachments
to show the images in the body when viewed through
the browser instead of the e-mail client.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 270772 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.7 Branch
You need to log in before you can comment on or make changes to this bug.