Loading a JavaScriptlet opens a new window instead of a new tab

VERIFIED DUPLICATE of bug 314721

Status

()

Firefox
Tabbed Browser
--
minor
VERIFIED DUPLICATE of bug 314721
12 years ago
12 years ago

People

(Reporter: Daniel Freitag, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

I activated the option 'force open in new tab', but the scriptlet of my preferred dictionary and I assume others two opens a new window.

It worked with TabMix and Fx 1.0.

Here the code for the scriptlet: 
javascript:s=(window.getSelection?window.getSelection():document.getSelection());if(s=='' || s==null){if(window.getSelection){if(frames.length!=1){for(i=0;i<frames.length;i++){s=frames[i].document.getSelection();if(s)break;}}}}if(s=='')void(s=prompt('Geben Sie einen Suchbegriff ein, oder markieren Sie den Text, den Sie %C3%BCbersetzen m%C3%B6chten, bevor Sie auf LEO dict klicken.',''));if(s!=null&&s!=''){leow=open('http://dict.leo.org/?lp=ende&search='+escape(s),'LEODict','width=750,height=550,scrollbars=yes,resizeable=yes');leow.focus();}

Reproducible: Always

Steps to Reproduce:
1. Activate 'force new tab'
2. Enter a bookmark with code of scriptlet.
3. Use bookmark to translate a word.

Actual Results:  
New window opens

Expected Results:  
New tab
Dupe of bug 55696?

Comment 2

12 years ago
See bug 314721.  You can work around this by removing the third parameter to window.open() in your copy of the bookmarklet.

*** This bug has been marked as a duplicate of 314721 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.