Changing identity during mail composition is broken

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: mozilla.jgvons, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

Seen for the first time with thunderbird 1.5 RC1 (not with the betas):

1. If after entering some recipients, I select another identity in the From drop-down, I still see the recipients I typed but when I hit "Send" TB says that "Sending of message failed. No recipients were specified".
If I then save the mail (with the recipients still displayed) as a draft and then reopen that draft there are indeed no recipients anymore.

2. If I change the identity _before_ entering recipients, I can only enter one recipient; the other To/CC lines don't allow me to enter any new e-mail addresses.

3. Lastly, sometimes when I open the From drop-down, I see all my accounts/identities listed twice. This happens after seeing problem 2 above: when I get problem 2, I quit the compose window by clicking on the close-button, open a new compose window, open the from: drop-down -> all identities are listed twice.

Once, I actually saw all my identities listed 3 times in the From: drop-down but  I don't know how to reproduce that.


Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

13 years ago
Hmmm, this is strange. I consistently have this problem on my computer at work but not at home. Both systems run XP-Pro, both have run earlier TB releases including 1.5beta1 and 2, and on both I uninstalled 1.5beta2 before installing 1.5rc1.

Assuming this would be caused by something in my TB config, anything I could try?

Comment 2

13 years ago
Related to/duplicate of Core bug 163701 or maybe the "Another way it fails:"-part of bug 288615 comment 0?
(Reporter)

Comment 3

13 years ago
I searched but didn't find the bugs mentioned in comment #2, they indeed seem similar. I also have a bcc on two of the identities as mentioned in bug #163701, and one also has a reply-to.

However, my problem seems to have gone. I noticed that when I clicked "manage identities" in the account settings dialog, it displayed only the username for one of the identities, not the e-mail addres like it does for the other ones. I could edit the identity in any way I wanted, it made no difference; the e-mail address never appeared.

I ended up deleting that identity and creating a new one, and my problem went away. So I guess the identity was somehow corrupt or not completely compatible with what TB1.5rc1 expected.

That identity was the one created with the account long ago before TB supported the separate identities. I ran TB betas when identities were introduced, and there were some issues with prefs.js at the time that had to be fixed manually (see bug #263911 for example).

Comment 4

13 years ago
Gert, can we close this as WFM then?

Comment 5

13 years ago
No response from reporter, WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

13 years ago
Oops, sorry for not answering comment 4. As mentioned I don't have the problem anymore after fixing the identities. And since no-one else has reported the same problem the bug can be closed of course.
You need to log in before you can comment on or make changes to this bug.