Link inside DL incorrectly rendered in a separate line.

RESOLVED INVALID

Status

()

RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: dmoisset, Unassigned)

Tracking

({testcase})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.7 Galeon/1.3.19
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.7 Galeon/1.3.19

The attached XHTML 1.0 document (valid, no CSS) is incorrectly rendered. The A element inside the DD is shown in a separate line from the previous text.

Reproducible: Always

Steps to Reproduce:
1. Open the given document
2.
3.

Actual Results:  
The rendered page is shown as:
...
Another DT
    This text contains a
[link], which is shown in a separate line. It shouldn't

Expected Results:  
The rendered page should look like:
...
Another DT
    This text contains a [link], which is shown in a separate line. It shouldn't 


The bug happens with or without CSS style information. The problem is not visible in every DL; it even disappears in the above example when removing the first div. I think it might even be a parsing error instead of a rendering problem.
(Reporter)

Comment 1

13 years ago
Created attachment 202394 [details]
XHTML document showing the problem

Updated

13 years ago
Keywords: testcase

Comment 2

13 years ago
Comment on attachment 202394 [details]
XHTML document showing the problem

Changing MIME type to be XHTML
Attachment #202394 - Attachment mime type: text/html → application/xhtml+xml

Comment 3

13 years ago
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

Please retest with Firefox 1.5 RC 1

Updated

13 years ago
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → 1.0 Branch

Comment 4

13 years ago
testcase works fine if you use an XHTML content-type.  You cannot override server headers with a meta tag; the headers take precedence.  So the page is processed as HTML, not XML.  The parser then tries to staighten out the mess, which leads to the display problem.
->invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Component: Layout → General
Product: Core → Firefox
QA Contact: layout → general
Resolution: --- → INVALID
Version: 1.0 Branch → unspecified
(Reporter)

Comment 5

13 years ago
If the doctype says XHTML1.1, with content-type text/html, shouldn't the document be processed as XHTML anyway? All the other browsers and the W3C validator do that

Comment 6

13 years ago
Firefox uses the doctype to switch between standards-compliance and quirks mode processing.  Otherwise it ignores it--it doesn't validate contents against the specified DTD, it just processes its notion of HTML or XHTML based on the content-type.

See http://developer.mozilla.org/en/docs/Mozilla%27s_Quirks_Mode for quirks mode info.
You need to log in before you can comment on or make changes to this bug.