Firefox 1.5 Korean (ko) trademark review - add search plugins of l10n ko locale

RESOLVED FIXED

Status

Marketing
Trademark Permissions
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: channy, Assigned: rebron)

Tracking

Details

Attachments

(7 attachments, 14 obsolete attachments)

868 bytes, image/gif
Details
965 bytes, image/gif
Details
795 bytes, text/plain
Details
88 bytes, image/gif
Details
755 bytes, text/plain
Details
943 bytes, text/plain
Details
734 bytes, text/plain
Details
(Reporter)

Description

12 years ago
I want to ask how to add search plugins  in ko local version by trademark issue. As you know, most of korean use their local search engine over 98%. (Market share: Naver 60%,  Daum 28%, Yahoo korea 5%, Empas 4%, Google and etc 1%)

So I want to add Naver and Daum's search plugin in korea version. Naver and Daum are 1st/2nd potal company in korea.
(Reporter)

Comment 1

12 years ago
Created attachment 202400 [details]
daum.src
(Reporter)

Comment 2

12 years ago
Created attachment 202401 [details]
daum.gif
(Reporter)

Comment 3

12 years ago
Created attachment 202402 [details]
naver.src
(Reporter)

Comment 4

12 years ago
Created attachment 202403 [details]
naver.gif
(Assignee)

Updated

12 years ago
Assignee: cbeard → rebron
Group: Marketing Private
(Reporter)

Comment 5

12 years ago
Daum and Naver maintain their search plugin files on as following url.

http://toolbar.daum.net/download/daum.src (daum.gif)
http://jump.naver.com/naver.src (naver.gif)

Comment 6

12 years ago
I can r- those from a technical point of view.

The plugins need to follow the naming convention, though in this case they're on
.net and .com. Still it be better to have them in daum-ko.src and naver-ko.src.

And the update needs to be from our secure server as laid out on http://wiki.mozilla.org/L10n:Firefox_Extras#Search_engine_plugins.
(Reporter)

Comment 7

12 years ago
Created attachment 202755 [details]
daum-ko.src
Attachment #202400 - Attachment is obsolete: true
(Reporter)

Comment 8

12 years ago
Created attachment 202756 [details]
naver-ko.src
Attachment #202402 - Attachment is obsolete: true
(Reporter)

Comment 9

12 years ago
Created attachment 202757 [details]
google-ko.src

mv google.src to google-ko.src and changes update url
(Reporter)

Comment 10

12 years ago
Created attachment 202758 [details]
yahoo-ko.src

mv yahoo.src to yahoo-ko.src and changes update url
(Reporter)

Comment 11

12 years ago
Created attachment 202969 [details]
daum-ko.src

change traffic check indicator.
Attachment #202755 - Attachment is obsolete: true
(Reporter)

Comment 12

12 years ago
Created attachment 202970 [details]
naver-ko.src

change traffic indicator
Attachment #202756 - Attachment is obsolete: true

Comment 13

12 years ago
As I wrote to you, you have to use 'x-windows-949' instead of 'EUC-KR' for Naver and Daum. Moreover, 'queryEncoding' is redundant (its value should be numeric, but is not refered to when 'queryCharset' is present) and should be removed. 

See 
http://bugzilla.mozdev.org/show_bug.cgi?id=9098
http://bugzilla.mozdev.org/show_bug.cgi?id=12124

Btw, I've submitted an update to naver.src to mycroft.mozdev.org.

http://mycroft.mozdev.org/update.php/id0/naver.src

Actually, I submitted two updates. The first one with a mistake is currently at the url given above. A few minutes later, I submitted a new version with that fixed, but it's not shown up yet at mozdev. 

Comment 14

12 years ago
For Yahoo-KR, you'd better use 'UTF-8' with 'ei=UTF-8'. For Google, they deprecated 'oe' and 'ie'. Although specifying them is harmless, there's no point in specifying them because Google always use UTF-8 whether they're specified or not. [1]



[1] http://www.google.com/apis/reference.html
(Assignee)

Comment 15

12 years ago
Created attachment 203196 [details]
From yahoo

Please check this one in for Yahoo.  This is what I got from them.
(Assignee)

Comment 16

12 years ago
Created attachment 203197 [details]
Yahoo! Search .gif

what I got from Yahoo
Attachment #202758 - Attachment is obsolete: true

Comment 17

12 years ago
Comment on attachment 203196 [details]
From yahoo

><SEARCH
>   version = "7.1"
>   name="Yahoo! Korea Search"
>   description="Yahoo! Korea Search"
>   searchForm="http://kr.yahoo.com/"
>   method="GET"
>   action="http://kr.search.yahoo.com/search"
>   routeType="internet"
>   queryEncoding="EUC-KR"
>   queryCharset="EUC-KR"

As I already wrote here and elsewhere, specifying queryCharset is more than enough. queryEncoding is NEVER refered to if queryCharset is present. Moreover, queryEncoding should be set to a numeric encoding ID (as opposed to the encoding name in string) if it is ever specified.
More importantly, there is NO reason to use EUC-KR because Yahoo-KR supports UTF-8 well. Just add a parameter 'ei' and set it to 'UTF-8'.
(Reporter)

Comment 18

12 years ago
I committed yahoo's change of update url, parameter and -ko.* to -kr.*.

Comment 19

12 years ago
(In reply to comment #18)
> I committed yahoo's change of update url, parameter and -ko.* to -kr.*.  

  What exactly did you check in? Attachment 203196 [details] without any change? 
(Reporter)

Comment 20

12 years ago
Yahoo-kr.src is given by yahoo inc. So it has better remain their setting.

Comment 21

12 years ago
(In reply to comment #20)
> Yahoo-kr.src is given by yahoo inc. So it has better remain their setting.

Even if their setting is INCORRECT?  They have little clue what they're doing and apparently mimicked  what others did (given from their inclusion of completely useless 'queryEncoding') . As I explained a couple of times, EUC-KR as interpreted by Yahoo, Naver, Daum IS different from the standard EUC-KR as emitted by Mozilla. [1] That difference leads to **wrong** search results.  One of these two has to be done to remedy that:

A. Replace *all* instances of 'EUC-KR' with 'x-windows-949' 

B. Replace 'queryCharset=EUC-KR' with 'queryCharset=UTF-8' and add an input entry 'ei' whose value is 'UTF-8'

Whichever option you take, queryEncoding should be removed. 
(Reporter)

Comment 22

12 years ago
x-windows-949 can be applied in linux or mac? Is it windows characterset?
I must test x-windows-949 search plugins in linux and mac tommorrow.

Comment 23

12 years ago
I wrote the converter for them in Mozilla. It works on all the platforms. 

Comment 24

12 years ago
(In reply to comment #23)
> I wrote the converter for them in Mozilla. It works on all the platforms. 

s/them/x-windows-949/

What specifying 'queryCharset=x-windows-949' does is to convert Mozilla's internal representation of a query string (which is UTF-16) to 'x-windows-949' before sending the query to Yahoo/Naver/Daum et al. It has NOTHING whatsoever to do with the locale character encoding on a particular platform.





Comment 25

12 years ago
jshin, do us all a favour and get over it.

All that data is not used in Firefox (besides the name in search), and the
middle of RC freeze cycle is not the szenario to discuss these.

Anything that isn't terribly block-ship should just go into different bugs.

Comment 26

12 years ago
(In reply to comment #25)
> jshin, do us all a favour and get over it.

I've been trying to help, but I'm afraid it's you guys that didn't listen. 

> All that data is not used in Firefox (besides the name in search), 

What did you mean? queryCharset IS used by firefox. [1] 
See bug 283180 and bug 270120. This issue is exactly the same as those handled in those bugs. 


> and the
> middle of RC freeze cycle is not the szenario to discuss these.

 
> Anything that isn't terribly block-ship should just go into different bugs.

There's nothing to discuss or debate here. It's been crystal clear what has to be done from the very beginning, but I may not have been very effective to get it known. 

The check-in went in in the middle of freeze. I specifically, here and off-line (not just once but a few times) wrote what needs to be done before that check-in to avoid breaking search plugins for Yahoo-KR/Naver/Daum. Yahoo-KR plugin is *broken* as it is in the tree. And, it'll hurt firefox in Korean market if it's left not fixed. 

[1] http://lxr.mozilla.org/seamonkey/source/xpfe/components/search/src/nsInternetSearchService.cpp#2718
: queryCharset is retrieved here.

And it is used to convert  UTF-16 to what's understood by the search engine here:

2742           char    *charsetData = nsnull;
2743           nsCAutoString queryencodingstrC;
2744           queryencodingstrC.AssignWithConversion(queryEncodingStr);
2745           if (NS_SUCCEEDED(rv = textToSubURI->ConvertAndEscape(queryencodingstrC.get(), uni, &charsetData)) && (charsetData)) 
(Assignee)

Comment 27

12 years ago
Comment on attachment 203196 [details]
From yahoo

><SEARCH
>   version = "7.1"
>   name="Yahoo! Korea Search"

Channy,
can you make name="Yahoo!"
change needs to be made in region.properties too.

>   description="Yahoo! Korea Search"
>   searchForm="http://kr.yahoo.com/"
>   method="GET"
>   action="http://kr.search.yahoo.com/search"
>   routeType="internet"
>   queryEncoding="EUC-KR"
>   queryCharset="EUC-KR"
>>
>
><input name="p" user>
><input name="sourceid" value="mozilla-search">
><input name="fr" value="moz2">
><input name="rls" value="org.mozilla:ko-KR:official">
>
>
><INTERPRET
>        browserResultType="result"
>        charset="EUC-KR"
>        resultEncoding="EUC-KR"
>        #resultTranslationEncoding="1"
>        resultListStart="<ol start=1>"
>        resultListEnd="|"
>        resultItemStart="<li>"
>        resultItemEnd="</font><br>"
>>
>
><browser
>    update="https://addons.mozilla.org/searchplugins/updates/yahoo-kr.src"
>    updateIcon="https://addons.mozilla.org/searchplugins/updates/yahoo-kr.gif"
>    updateCheckDays="3"
>>
>
></search>
(Assignee)

Comment 28

12 years ago
1) Search order for Korea in region.properties should be:
browser.search.order.1=Yahoo!
browser.search.order.2=Google
browser.search.order.3=Naver
browser.search.order.4=Daum
browser.search.order.5=Amazon.com
browser.search.order.6=eBay
browser.search.order.7=Creative Commons

2) Remove Answers.com
(Assignee)

Comment 29

12 years ago
jshin, are you saying that the Yahoo, Naver, and Daum plug-ins are completely broken?  Are you also saying that the fix isn't with the .src file, or can we fix the .src file to make these plug-ins work?



(In reply to comment #26)
> (In reply to comment #25)
> > jshin, do us all a favour and get over it.
> 
> I've been trying to help, but I'm afraid it's you guys that didn't listen. 
> 
> > All that data is not used in Firefox (besides the name in search), 
> 
> What did you mean? queryCharset IS used by firefox. [1] 
> See bug 283180 and bug 270120. This issue is exactly the same as those handled
> in those bugs. 
> 
> 
> > and the
> > middle of RC freeze cycle is not the szenario to discuss these.
> 
> 
> > Anything that isn't terribly block-ship should just go into different bugs.
> 
> There's nothing to discuss or debate here. It's been crystal clear what has to
> be done from the very beginning, but I may not have been very effective to get
> it known. 
> 
> The check-in went in in the middle of freeze. I specifically, here and off-line
> (not just once but a few times) wrote what needs to be done before that
> check-in to avoid breaking search plugins for Yahoo-KR/Naver/Daum. Yahoo-KR
> plugin is *broken* as it is in the tree. And, it'll hurt firefox in Korean
> market if it's left not fixed. 
> 
> [1]
> http://lxr.mozilla.org/seamonkey/source/xpfe/components/search/src/nsInternetSearchService.cpp#2718
> : queryCharset is retrieved here.
> 
> And it is used to convert  UTF-16 to what's understood by the search engine
> here:
> 
> 2742           char    *charsetData = nsnull;
> 2743           nsCAutoString queryencodingstrC;
> 2744           queryencodingstrC.AssignWithConversion(queryEncodingStr);
> 2745           if (NS_SUCCEEDED(rv =
> textToSubURI->ConvertAndEscape(queryencodingstrC.get(), uni, &charsetData)) &&
> (charsetData)) 
> 

Comment 30

12 years ago
(In reply to comment #29)
> jshin, are you saying that the Yahoo, Naver, and Daum plug-ins are completely
> broken?  Are you also saying that the fix isn't with the .src file, or can we
> fix the .src file to make these plug-ins work?

Phew. they're not completely broken, but nonetheless broken in that some query strings are not properly encoded when sent to those search engines because queryCharset is incorrectly specified in *.src files.

I outlined how to fix src files a couple of times right here (see comment #13 and references therein, comment #14, comment #17, comment #21). Even all those comments are not clear enough, I'll upload fixes here. 

Comment 31

12 years ago
Created attachment 203347 [details]
Yahoo KR with x-windows-949

Comment 32

12 years ago
Created attachment 203348 [details]
Yahoo-KR with UTF-8
(Reporter)

Comment 33

12 years ago
Created attachment 203356 [details]
daum-ko.src

changed encoding x-windows-949 in daum-ko.src
(Reporter)

Comment 34

12 years ago
Created attachment 203357 [details]
naver-ko.src

changed encoding x-windows-949 in naver-ko.src
Attachment #202970 - Attachment is obsolete: true
(Reporter)

Updated

12 years ago
Attachment #202969 - Attachment is obsolete: true
(Reporter)

Comment 35

12 years ago
Created attachment 203359 [details]
yahoo-ko.src

- changed Yahoo! Korea Search to Yahoo. (also changed region.properties, search order Yahoo! Korea search to Yahoo.) Rafael's Yahoo! is misspelled.
- changed euc-kr to utf-8 by attachment of jshin. (I and rafael tested on windows and linux)

It need to be confirmed by Axel.
Attachment #203196 - Attachment is obsolete: true
Attachment #203347 - Attachment is obsolete: true
Attachment #203348 - Attachment is obsolete: true
(Reporter)

Comment 36

12 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla1.8-l10n-ko/1132218900.22160.gz

> Properties in ./chrome/browser-region/region.properties don't match:
>  In /builds/tinderbox/Fx-Mozilla1.8-> l10n/Darwin_7.9.0_Clobber/mozilla/../l10n/ko/browser: (remove these from your localization)
>    browser.search.order.7
>    browser.search.order.3
>    browser.search.order.4
>    browser.search.order.5
>    browser.search.order.6

There is a problem on tinderbox (test-failed). it originated in addred search.order by guidance of rafael. How do it?

Comment 37

12 years ago
The compare-locales problem is bug 316674.

The queryEncoding in naver is wrong (just drop it), the descriptions need to be 
either ASCII, or you need to specify sourceTextEncoding in the search tag, with 
the numeric identifier defined here,
http://lxr.mozilla.org/seamonkey/source/xpfe/components/search/src/nsInternetSearchService.cpp#3821

I hope I got that right this time, jshin?
(Reporter)

Comment 38

12 years ago
Created attachment 203360 [details]
naver-ko.src

changed from utf-8 to ascii, naver-ko.src
Attachment #203357 - Attachment is obsolete: true

Comment 39

12 years ago
In reply to comment #37)

> The queryEncoding in naver is wrong (just drop it), the descriptions need to be 
> either ASCII, or you need to specify sourceTextEncoding in the search tag, with 
> the numeric identifier defined here,
> http://lxr.mozilla.org/seamonkey/source/xpfe/components/search/src/nsInternetSearchService.cpp#3821
> 
> I hope I got that right this time, jshin?

Yes, you're right. It sucks that UTF-8 cannot be used at all for sourceTextEncoding, let alone the fact that it is not the default(MacRoman is the default). I don't know how important it is to keep our searchplugins compatible with Sherlock. If it's not that important, I would overhaul that part of the code and make UTF-8 the default. Well, that's a separate issue.

Channy, if you wanna use a Korean string for 'description' or 'name', you have to add 

sourceTextEncoding="3"

to "search" (where '3' is the encoding code for EUC-KR) and make the search plugin source in EUC-KR. 

Also, please get rid of queryEncoding (in daum-ko.src and naver-ko.src) which is spurrious. 
(Reporter)

Comment 40

12 years ago
Created attachment 203389 [details]
daum-ko.src final
Attachment #203356 - Attachment is obsolete: true
(Reporter)

Comment 41

12 years ago
Created attachment 203390 [details]
yahoo-kr.src final
Attachment #203359 - Attachment is obsolete: true
(Reporter)

Comment 42

12 years ago
Created attachment 203392 [details]
naver-ko.src final
Attachment #203360 - Attachment is obsolete: true

Updated

12 years ago
Blocks: 307393
Summary: Firefox 1.5 trademark review - add search plugins of l10n ko locale → Firefox 1.5 Korean (ko) trademark review - add search plugins of l10n ko locale
(Assignee)

Comment 43

12 years ago
Axel, Channy,

Can you guys check to make sure answers.com is NOT in korean builds.  We need to have that removed.
(Reporter)

Comment 44

12 years ago
if someone approve to delete answers.com files, I'll do that. BTW, It seems not to work search order by region.properties. In ko nightly, it was ordered by alphabet execpt yahoo, google.

Comment 45

12 years ago
It might be a bit off-topic here, but it's being dealt with here.... IMHO, 'answers.com' is (a lot) more useful to Korean users than 'eBay.com' (which doesn't even accept a Korean string although it has an affiliate, which is not so firefox-friendly, in Korea). Unless there's a agreement between eBay and MoCo, keeping answers.com and getting rid of eBay.com would make more sense.
(Assignee)

Comment 46

12 years ago
Hi Channy,

Can you get rid of both Answers.com and eBay from this list?  

Thanks.  
(Reporter)

Comment 47

12 years ago
By comment #46 I deleted ebay and answers plugins from ko locale.
Rafael, must I change search order in region.properties? reopen bug #316627.
(Assignee)

Comment 48

12 years ago
marking fixed
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.