bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Toolbar icons should be less similar to eachother

RESOLVED WORKSFORME

Status

Calendar
General
--
enhancement
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: Gijs, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
The toolbar buttons on the default toolbar in the default theme in sunbird are very similar to eachother. This is confusing, as the first impression a user gets is that there's about 6 buttons on the toolbar that probably all do a similar thing. Only on closer inspection, or on reading the text beneath the icons (which is on by default - good in this case!), would a user know what the buttons are used for.

Possible attempts at a solution (they're not all very good, but it's what I can come up with at the moment)
- Make the toolbar icons for Event and Task be less square-like, and more distinct  from eachother if at all possible.
- Make the different view types into one dropdown button, or change the location of items like these (make them text on/off buttons above the main calendar but under the toolbar, perhaps)
- Add more of the other, distinct icons by default. This could include Print, Subscribe and Publish, maybe. I'm not sure what they do and how useful they are in general, this is the first time I've used a calendar application (which is why I'm filing first-time-impression bugs).
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody

Comment 2

12 years ago
Created attachment 244259 [details]
current icons

Comment 3

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061031 Calendar/0.4a1

New Sunbird has IMHO quite nice icons, not so similar. However don't think you use icons very often because drag&drop is supported. It is common for begginers but then users click main view and this is easier to create/modify events/tasks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
No, this bug is valid. 7 square icons with similar colors is not good.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 5

12 years ago
I think it'd help to just use the number of days in the icon?

IE, 1 for day view, 7 for week view, 31 for month view. I'm not sure what to do about multiweek view. You could do n x 7 or whatever, but that wouldn't be iconic anymore, and since the length is pref-able, it wouldn't make sense to hardcode it to display 28 days.

Comment 6

12 years ago
Internationalization (foreign language support) weighs against putting numbers in the day view icons (month, multi-week, week, day). While may languages use arabic numerals (0..9), most Eastern/Oriental languages do not.
(Reporter)

Comment 7

11 years ago
So if putting numbers in them isn't a good plan, are there better alternatives? I still think the current icons aren't all that brilliant (per comment #4)
Component: Sunbird Only → General
Keywords: uiwanted
QA Contact: sunbird → general
Version: Sunbird 0.3a1 → unspecified

Comment 8

11 years ago
I really don't care either way (numbers or not on the view icons) but I appreciate the internationalization issues which is why the numbers were removed early in the icon design process back in 2005.

BTW - The copy of MS Outlook I have to use at work has view icons (1 day, work week/5 days, week/7 days, and month) which are all identical except for a large number over the calendar icon. All in blue, all the same full month icon. Just the number differs. The New Appointment and New Meeting Request icons are also based on the same blue full month calendar icon. 

I know we would like to do a better job than Outlook, but I just wanted to point out that this reuse of a basic calendar icon is not uncommon. If someone has better ideas, let's hear them.
Adding Jordan to CC, maybe he's interested and has some ideas how the icons could be improved.

Comment 10

11 years ago
I'm not that off put by the icons being the same basic size and shape (square). I think that this is ok but the contents (and colours) of each icon can differ more and represent it's intended function a little more uniquely though I would like to keep them the same "style".

I might suggest for "day view" we could use the "single day" pad calendar where you rip a page off the calendar pad each day. For week, and multi-week I think they should have a related theme but we might be able to design something with a more clear seperation... for month view I'm thinking about a two page (one above the other) folding calendar view but this may be hard to do while keeping a nice relative width... where the top half shows an iconic photo such as a mountain view.

This would provide some nice visual seperation while keeping everything relevant. The overall artistic style of the icons should have a common theme.

I'll take a shot at this and upload an attachment.
Please note that this bug is not only about the view-switching buttons. The new event, new task and go to today buttons also are very similar to each other (and to the view switch buttons). For those, it should be less of a problem to create new images.

Comment 13

11 years ago
Go for it. Keep in mind that the toolbar icon sizes in the current Sunbird theme are 24x24 and 16x16, so part of the challenge is making icons that still make sense at 16x16 when the small icons are selected. Themes (in FF and TB) that use 32x32 for large and 24x24 for small icons have more canvas to play with which opens more artistic possibilities.

Comment 14

11 years ago
I noticed that the large pinstripe set Sephan linked appears to be 32 pixel tall. The small pinstripe icon set look to be about 24 pixels tall. The winstripe sets are 32 and 24 respectively.
If sunbird icons are being changed in bug 401883, this should be duplicate?
Is this still valid? The new icons are quite differing, so i think we can close this bug. Please reopen if you concur.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago9 years ago
Resolution: --- → WORKSFORME
Keywords: uiwanted
You need to log in before you can comment on or make changes to this bug.