Unable to reload a single frame

VERIFIED FIXED in M18

Status

SeaMonkey
UI Design
P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: Thomas Stinner, Assigned: Bill Law)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

19 years ago
Right-Clicking on a frame and selecting reload does not reload the frame, but
the hole frameset giving all kind of problems.
t.stinner@billiton.de - can you please provide a URL where this problem can be 
seen? Also, your Mozilla Build ID (looks something like 2000031412) which is in 
the bottom right corner of your Mozilla window. Can you also elaborate on what 
sort of problems you are seeing?

Gerv

Comment 2

18 years ago
build 200032018  Win98, 128mb.

This happens on ANY page with frames.
One is: http://www.io.com/~crawdad  
1- Make a selection in right-hand frame.
2- select left-hand frame, right-click/reload
3- Entire frameset reloads.

This is not surprising, considering that thewre IS no "reload frame" option, 
just "reload".
This is major and must be fixed.
Confirming, upping severity, moving to HTMLFrames. Lads: do you need this for 
beta? :-)

Gerv
Assignee: cbegle → pollmann
Severity: normal → critical
Component: Browser-General → HTMLFrames
QA Contact: asadotzler → petersen

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

18 years ago
Given that the beta will have WIDE exposure, it would be pretty bad to have this 
broken... 
Tough to convince people to use it like this.
This is pretty major funtionality to be missing.
I vote fix for beta if at ALL possible.

Comment 5

18 years ago
This request comes a little late to make the 'beta train'.  Sounds like a
reasonable thing to try to get into beta2 though.

Handing this off to Bill (Contextual menus) and Ben (Implemented
BrowserReallyReload).  Let me know if I can help, thanks!
Assignee: pollmann → law
Component: HTMLFrames → XP Miscellany
OS: Linux → All
Hardware: PC → All

Comment 6

18 years ago
yeah, I vote for m15, I just needed this :(

(Assignee)

Comment 7

18 years ago
OK, I'm setting target for M15 (hopefully it isn't hard at all).

I've reduced the severity, though.  I find it hard to believe that it's 
*critical* that you be able to reload a single frame (versus reloading the whole 
frameset).  What's the big deal with that?  Maybe I'm missing something?
Severity: critical → normal
Target Milestone: --- → M15

Comment 8

18 years ago
Governmental grant-allovation app using cascading form variables from frame to 
frame 3 deep... 
Reloading frameset blows whole app out of the water.
This IS critical in some cases.

Comment 9

18 years ago
Correction: "Allocation", not "allovation"

Addition: 
Of course, since reload does not repost form-data, this borders on being moot.
Thes BOTH need to get fixed if Moz is to be useful for SERIOUS work.

Comment 10

18 years ago
*** Bug 33582 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
*** Bug 34269 has been marked as a duplicate of this bug. ***

Comment 12

18 years ago
Move to M16 for now ...
Target Milestone: M15 → M16

Comment 13

18 years ago
*** Bug 35306 has been marked as a duplicate of this bug. ***

Comment 14

18 years ago
*** Bug 35306 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Depends on: 23567

Comment 15

18 years ago
*** Bug 37661 has been marked as a duplicate of this bug. ***

Comment 16

18 years ago
moving to m18.
Target Milestone: M16 → M18

Comment 17

18 years ago
Nominating for NS Beta 2 per pollmann's comments, and per huge number of 
duplicates.
Keywords: nsbeta2

Comment 18

18 years ago
When I was a kid we had to walk to school, with no shoes on, uphill both ways.  
In the snow.  And we had bugs with lots of duplicates, like bug 14827.  ;)

Comment 19

18 years ago
Putting on [nsbeta2+] radar for beta2 fix.
Whiteboard: [nsbeta2+]
(Assignee)

Comment 20

18 years ago
Hey, do we want the context menu label to read "Reload Frame" when it's going to 
just reload the frame?  That's how it works in Communicator and if it's only 
going to reload  the frame perhaps we should say so.
Status: NEW → ASSIGNED

Comment 21

18 years ago
i like the idea :)
(Assignee)

Comment 22

18 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 23

18 years ago
Fixed in the June 26th build (2000062608).
Status: RESOLVED → VERIFIED

Updated

13 years ago
Component: XP Miscellany → XP Apps: GUI Features
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.