"New window" item no longer in dock menu

VERIFIED FIXED in Camino1.0

Status

VERIFIED FIXED
14 years ago
13 years ago

People

(Reporter: mikepinkerton, Assigned: mark)

Tracking

({fixed1.8, regression})

unspecified
Camino1.0
PowerPC
macOS
fixed1.8, regression
Bug Flags:
camino1.0 +

Details

Attachments

(1 attachment)

32.44 KB, application/octet-stream
mikepinkerton
: review+
Details
The "new window" menu item in the dock menu has gone missing. Reward for its return. If found, please post patch here in this bug.
I can't bring you back "new window" (or his buddy, "open in tabs"), but I do have a regression window for you:

http://tinyurl.com/7l3qg

(Why is it things always break in a window where we're missing a build).

You, Mark, and Simon made Camino checkins in that window, but none of them touched MainMenu.nib...?
Keywords: regression

Updated

14 years ago
Flags: camino1.0+

Comment 2

14 years ago
I very much doubt it has to do with the nib file since the item is in place there and is hookedup correctlt. My guess is some change in code caused the removal.

A lot of changes where made in the week of 2005-07-30 till 2005-08-04 so I'm assuming something in the code that enables that menu tems was broken in that time.
(Assignee)

Updated

14 years ago
Assignee: mikepinkerton → mark
(Assignee)

Comment 3

14 years ago
This was almost certainly fallout from Simon's NSMenu reworking.  I found the dock menu's mItemBeforeCustomItems was not connected to the separator's NSMenuItem, and in fact, it was not connected to anything at all.  In this nib, the connection is made.

There's some additional code cleanup that can be done here: there are a few methods and constants that might now be dead and removable.
Attachment #202544 - Flags: review?(mikepinkerton)
(Assignee)

Comment 4

14 years ago
P.S. What's the reward I've heard talk about?
Comment on attachment 202544 [details]
New MainMenu.nib/keyedobjects.nib

the journey is the reward.

*ducks*

r=pink, though i didn't try it.
Attachment #202544 - Flags: review?(mikepinkerton) → review+
(Assignee)

Comment 6

14 years ago
Fixed, trunk and branch.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Keywords: fixed1.8
Resolution: --- → FIXED

Comment 7

14 years ago
Thanks!
FWIW, Mark's fix didn't bring back "Open it tabs" for the Dock menu (which appeared at the bottom of the list of Dock menu bookmarks after a blank line).

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.