Font changes when starting a numbered list

RESOLVED DUPLICATE of bug 250539

Status

Thunderbird
Message Compose Window
--
trivial
RESOLVED DUPLICATE of bug 250539
12 years ago
12 years ago

People

(Reporter: oktavist, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Thunderbird version 1.5 (20051025)

I have changed the default composition font when composing in HTML to Comic Sans.
I now want to add a numbered list using the "Numbered List" button.
If start the numbered list as a first thing on a new line, it will switch
to Times Roman and stay this way until I manually change the font.
If I start typing in Comic Sans and start the numbered list after typing at least
one character, it will start the list in Comic Sans (my default font).

Problem also happens when ending the list:
If simply press "Backspace" on a new number in the list, it will stop the numbering but switch to Times Roman. If start typing and THEN disable the list
via the button, then it stays in the original font.

Reproducible: Always

Steps to Reproduce:
1. Make sure you compose mail in HTML format
2. Modify your default font to, say, Comic Sans
3. Type a few characters in the default font
4. After pressing <Enter> to open a new line, start the numbered
   list immediately. You should see the font change to Times Roman.



Expected Results:  
The font should stay the same when opening the numbered list, unless specifically stated otherwise.
It should also stay the same when I finish the numbered list.

Comment 1

12 years ago
This isn't a trivial bug, btw.

*** This bug has been marked as a duplicate of 250539 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.