flag based search for more than one flag does not work

RESOLVED DUPLICATE of bug 181396

Status

()

Bugzilla
Query/Bug List
RESOLVED DUPLICATE of bug 181396
12 years ago
12 years ago

People

(Reporter: pavel, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

If a bug has more than one flag set (i.e. UATed+, Deployed+) the following search does not work correctly:

"Flag" "is equal" "UAT+" And "Flag" "is not equal" "Deploy+"

Regardless of the second condition on the Flag field all bugs with "Flag" "is equal" "UAT+" will be returned.

I've tried different operations (i.e. contains/matches/regexp) but the reason I suspect in the resultset returned.

When bugs table is joined with flags table the result set will have two records for the same bug with two different flag values. So I suspect this causes the issue.


Reproducible: Always

Steps to Reproduce:
1. Create two flags: UAT, Deploy
2. Create a few bugs and set both flags on one, only UAT+ on next, only Deploy+ on next
3. Search for "Flag" "is equal" "UAT+" And "Flag" "is not equal" "Deploy+". It will return all bugs with UAT+ regardless of the second flag value.

Actual Results:  
Search returns all bugs with UAT+ regardless of the second flag value.

Expected Results:  
Search should return only bugs with UAT+ flag set and Deploy flag not set.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 181396 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.