Highlight radio button / check box when you mouse-over its label

RESOLVED DUPLICATE of bug 171255

Status

()

Firefox
Shell Integration
--
trivial
RESOLVED DUPLICATE of bug 171255
12 years ago
12 years ago

People

(Reporter: BoffinbraiN, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

In Windows and other OSs, hovering over an item (esp. check boxes, radio buttons and command buttons) or its label (caption) will highlight the item with a coloured border or similar visual cue.

This works in Firefox too, but only over the item itself - NOT for the label (<label for=""></label>).  There is no confirmation until the label is clicked on.

Reproducible: Always

Steps to Reproduce:
Move your mouse over the label for a radio button / check box in a web page that has such a form item.
Actual Results:  
No visual cue from the form item.  Also, when the item is clicked on, you get an ugly dotted border around it, rather than its label.

Expected Results:  
Mouse-over triggers visual cue for the form item.

I don't particularly want to mention Internet Explorer, but in this situation Firefox should behave exactly how IE does (since it is essentially a part of the OS anyway).

This is trivial, but sometimes quite frustrating for users, especially for those with poor mouse coordination.

When I say "I", I mean "a user".  If I expect to see the item highlighted when I hover over the label, and it doesn't, I assume there isn't one.  Alternatively I may just click on the text that appears next to the form item, and get frustrated when the form item is not checked.
(Reporter)

Comment 1

12 years ago
Correct me if I'm wrong, but I'm sure this bug also occurs in Linux.  Therefore, I have made this bug applicable to all operating systems.
(Reporter)

Comment 2

12 years ago
Created attachment 202540 [details]
Ugly dotted border appears around the radio button, instead of the label.

Comment 3

12 years ago
Duplicate of bug 253611 -> Core bug 171255?
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> Duplicate of bug 253611 -> Core bug 171255?
> 

I searched the bug list many, many times for keywords related to this bug, but nothing came up.  Clearly bug 171255 is identical to this, so I'll resolve it.  Please vote for bug 171255 !

*** This bug has been marked as a duplicate of 171255 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.