Closed Bug 31601 Opened 20 years ago Closed 19 years ago

Win+R in Windows doesn't cause context menus to dismiss

Categories

(Core :: XUL, defect, P3, trivial)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED
Future

People

(Reporter: dean_tessman, Assigned: hyatt)

References

()

Details

Steps To Reproduce:
1. Right-click on a document.
2. Press Windows+R (hold down the Windows key while pressing R)

Expected Results:
Windows Run dialog appears, Moz receives a WM_KILLFOCUS, and the context menu is 
dismissed

Actual Results:
Windows Run dialog appears, context menu remains

Additonal Notes:
Doesn't happen for popup menus liked to the menu bar.  I'm guessing because the 
listener is different.

Build: 2000031208
Confirmed as reported on WinNT, using 2000-03-13-17-M15-nb1b. I seem to remember 
something similar happening when switching desktops on Linux. The context menu 
does dismiss as soon as ALT or ALT+(anything) is pressed.

Using NN 4.72, Win+R and the Win key by itself both dismiss a context menu
before taking their action in the Win32 shell.
Severity: normal → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: 4xp
...
Status: NEW → ASSIGNED
Target Milestone: M20
Mass move of all M20 bugs to M30.
Mass move of M20 bugs to M30
Target Milestone: M20 → M30
Hyatt, any chance that what you did for Alt+Tab (bug 29261) would address this 
as well?  If so, and you can point me to some code, I'll try to code in the 
Win+R handling.
Mass-moving all M20-M30 XPToolkit bugs to Future
Target Milestone: M30 → Future
*spam*: transferring current XP Menu bugs over to jrgm, the new component owner.
feel free to add me to the cc list (unless am the Reporter) of any of these, if
you have any questions/etc.
QA Contact: sairuh → jrgm
Can't reproduce with build 2001030920 win32 on win98. Is this an NT only bug?
This seems to be one of those bugs where you have to have a menu item 
selected.  See bug 45108.  Can you reproduce it now?
Depends on: 45108
fixed.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
vfy
Status: RESOLVED → VERIFIED
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.