"Copy Value" does not copy value of selected dom node

RESOLVED DUPLICATE of bug 255528

Status

RESOLVED DUPLICATE of bug 255528
13 years ago
11 years ago

People

(Reporter: liegler.maurer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915

"Copy Value" action on any node in "Object - Javascript Object" view results always in text "[object HTMLDivElement]".

Reproducible: Always

Steps to Reproduce:
1. Open some page in DOM Inspector
2. Open view "Object - Javascript Object"
3. Browse some properties.
4. Right click on a property.
5. Select "Copy Value" action.
6. Insert into e.g notepad.
7. The text [object HTMLDivElement] is always returned.

Actual Results:  
[object HTMLDivElement]

Expected Results:  
value of property as shown in column "value"

Annoying because you can not read/reproduce long property values.
(Reporter)

Comment 1

13 years ago
btw "[object HTMLDivElement]" because target node's value has been [object HTMLDivElement].
This bug is a dupe of an already-filed DOM Inspector bug.
Whiteboard: DUPEME

*** This bug has been marked as a duplicate of 255528 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Assignee: dom-inspector → nobody
QA Contact: timeless → dom-inspector
You need to log in before you can comment on or make changes to this bug.