AppleWorks files cannot be sent as attachments

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: michael.graubart7, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051110 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051110 SeaMonkey/1.5a

If an AppleWorks database or word-processing document is attached to an e-mail and sent, the e-mail takes some time to load when it is received (suggesting that the attachment is there), but when the e-mail is opened in SeaMonkey Mail, no attachment can be found.

If (instead of downloading the message to SeaMonkey) the message is viewed directly on my ISP's website (http://home.bt.yahoo.com/), the message is listed in the main mail page with a paper-clip, indicating the presence of an attachment, but again when I click on the paper-clip icon no attachment appears, showing that the disappearance of the attachment occurs before the message is viewed in SeaMonkey Mail. I have used AppleWorks 6.2.9 (the only version for Mac OS X) in this investigation.

The problem occurs in SeaMonkey Build 2005111010, but there is no similar problem with Mozilla 1.7.12.

MS Word files can be sent in SeaMonkey with no problems. And the AppleWorks problem occurs though I have checked that the names of the files contain no unallowed symbols.

Reproducible: Always

Steps to Reproduce:
1. Create an AppleWorks WP or database document.
2. Attach it to an e-mail addressed to yourself.
3. Send.
4a. Pick it up by going to the ISP's website.
4b. Download it to SeaMonkey Mail and open it.

Actual Results:  
4a: The message is shown as having an attachment (paper-clip icon), but no attachment can be accessed.

4b: No attachment is shown at all.

Expected Results:  
In each case, the attachment should be capable of being accessed and downloaded to one's desktop.

eMac G4, OS X 10.3.9, Classic theme. AppleWorks 6.2.9.
(Reporter)

Comment 1

13 years ago
A little more information: 
1. An AppleWorks Draw document also fails to get through.
2. If both an AppleWorks document and a MS Word document are attached to the same e-mail, the message arrives with the Word attachment accessible, but no sign of the AW one.
3. JPEGs can be attached with no problem. (I have not tried an AW drawing saved as a JPEG.)
(Reporter)

Comment 2

13 years ago
Sorry; should have tried this first. An AppleWorks drawing saved as a JPEG (AW 6.2.9 saves it as a QT JPEG) can be attached and retrieved with no problems.
(Reporter)

Comment 3

13 years ago
I have discovered another kind of file that cannot be sent by SeaMonkey 2005111309 (but can be sent as an attachment in Mozilla 1.7.12): a music-notation file created by Finale 2004b. I have also further confirmed that it is a matter of how files are encoded when sent by SeaMonkey (and not when received): a Finale file sent by Mozilla 1.7.12 can be picked up in SeaMonkey, but one sent by SeaMonkey cannot.

This is a serious matter. I have done my testing by sending e-mails to myself, but when sending an e-mail to someone else there is no way of being warned that an attachment has not been sent in such a way that it can be seen and read by the recipient.
(Reporter)

Comment 4

13 years ago
I have made a further alarming discovery, this time going back all the way to Mozilla 1.7.13. I have again tried sending attachments from Mozilla 1.7.13, but have opened and downloaded them directly from my ISP's mail page.

Finale 2004b music document: this can be picked up, but it has turned into an  MS Excel binary document!!!. (When sent from the Mac's own mail client, it arrives as a proper Coda* music-notation file. When sent from SeaMonkey 2005111309, it cannot be seen or downloaded at all.)

AppleWorks 6.2.9 word-processing document: this arrives OK. (When sent from SeaMonkey 2005111309, it cannot be seen or downloaded at all.)

* The organization that makes Finale is called Coda. <http://www.finalemusic.com>
(Reporter)

Comment 5

13 years ago
Re ##3 and 4:in Build 2005111710, Finale music-notation files CAN now be sent as attachments and received uncorrupted. But AppleWorks files still disappear completely.
(Reporter)

Comment 6

13 years ago
I have updated my Mac operating system to Tiger (10.4.4). Using SeaMonkey 1.0, this bug is no longer apparent, but in the trunk Mac build dated 8.02.2006 it is still there.
(Reporter)

Comment 7

11 years ago
Now WFM in both trunk and 1.1.2 builds.
(Reporter)

Comment 8

11 years ago
Apologies: I should have said that it works both for AppleWorks and for Finale files in both versions of SM.

Comment 9

11 years ago
excellent. => WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.