If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

CSS selection not used when navigating

RESOLVED DUPLICATE of bug 216537

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 216537
12 years ago
12 years ago

People

(Reporter: Daniel Qarras, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915

In a site that allow several CSS choices from View->Use Style if one selects other than the default style and then opens some other page from the same site offering the same CSS choices the default is used, not the one that was selected before selecting a link.

This is important in sites that provide text-only/low-bw variants when used over modem or other non-broadband connection. Also important if using so visually better suitable CSS.

Reproducible: Always

Steps to Reproduce:
1. Open http://www.w3.org/Style/CSS/
2. View->Use Style->Steely
3. Follow a link like "learning CSS" in the introduction. The new page does not use the selected "Steely" style altough it would be available.

Actual Results:  
The new page does not use the selected style altough it would be available.

Expected Results:  
The new page does use the selected style if it would be available.

Setting severity to major because this is a real PITA when browsing over GSM.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 216537 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.