Caret not drawn properly in address and search fields

RESOLVED DUPLICATE of bug 260604

Status

()

Firefox
Toolbars and Customization
--
trivial
RESOLVED DUPLICATE of bug 260604
13 years ago
13 years ago

People

(Reporter: Mark Erikson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5

After upgrading to Firefox 1.5 RC2, I noticed that the caret is not being drawn properly in the address and search fields.  Instead of being a completely vertical bar, there are a couple of extra pixels extending to the right of the caret, just a few pixels below the top.  This behavior did not exist in RC1.  The cursor displays properly in actual webpages.  I'll attach a screenshot for illustration.

Reproducible: Always

Steps to Reproduce:
1. Run Firefox
2. Click in either the address field or the search box, then click again to remove the selection.
3. Observe the extra pixels on the caret.

Actual Results:  
The caret is misdrawn.

Expected Results:  
The caret should be properly drawn (ie, a perfectly straight vertical line).
(Reporter)

Comment 1

13 years ago
Created attachment 202721 [details]
Screenshot of the caret drawing problem.
I have to agree. I've always found this "backwards-one" look for the caret annoying. Why is this shown when people don't have a use for the bidirectional text?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Are you sure this was not happening in RC1? As Tuuka mentions, this is likely a dupe of bug 260604. Did you recently change your sidebar using the CSS hack mentioned at bug 260604 comment 4? Do you have other bidirectional text in your chrome?
Yes, this was in RC1 for me. Thanks to logan's assistance on IRC with figuring out the common extensions, it seems User Agent Switcher causes this for me, at least.

Anyway, this is a DUPE of bug 260604.

Basically, reporter, you have either changed something to use bidirectional text or an extension is causing the problem.

*** This bug has been marked as a duplicate of 260604 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

13 years ago
(In reply to comment #5)
> Yes, this was in RC1 for me. Thanks to logan's assistance on IRC with figuring
> out the common extensions, it seems User Agent Switcher causes this for me, at
> least.
> 
> Anyway, this is a DUPE of bug 260604.
> 
> Basically, reporter, you have either changed something to use bidirectional
> text or an extension is causing the problem.
> 
> *** This bug has been marked as a duplicate of 260604 ***
> 

I do have User Agent Switcher installed.  It sounds as if this is a known issue, so that would explain it.
You need to log in before you can comment on or make changes to this bug.